summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS4
-rw-r--r--meson.build19
-rw-r--r--meson_options.txt4
-rw-r--r--shell-completion/bash/resolvectl12
4 files changed, 20 insertions, 19 deletions
diff --git a/NEWS b/NEWS
index 44ae6de03..2ff624602 100644
--- a/NEWS
+++ b/NEWS
@@ -53,8 +53,8 @@ CHANGES WITH 239 in spe:
configuration settings to change the resolution explicitly.
* The elogind-resolve tool has been renamed to resolvectl (it also
- * elogind-resolved now supports DNS-over-TLS ("PrivateDNS"). It's still
- turned off by default, use PrivateDNS=opportunistic to turn it on in
+ * elogind-resolved now supports DNS-over-TLS. It's still
+ turned off by default, use DNSOverTLS=opportunistic to turn it on in
resolved.conf. We intend to make this the default as soon as couple
of additional techniques for optimizing the initial latency caused by
establishing a TLS/TCP connection are implemented.
diff --git a/meson.build b/meson.build
index b7326427b..46a4d05d6 100644
--- a/meson.build
+++ b/meson.build
@@ -1300,17 +1300,17 @@ conf.set10('HAVE_DBUS', have)
# 'DNSSEC_' + default_dnssec.underscorify().to_upper())
# substs.set('DEFAULT_DNSSEC_MODE', default_dnssec)
#
-# default_private_dns = get_option('default-private-dns')
+# default_dns_over_tls = get_option('default-dns-over-tls')
# if fuzzer_build
-# default_private_dns = 'no'
+# default_dns_over_tls = 'no'
# endif
-# if default_private_dns != 'no' and conf.get('HAVE_GNUTLS') == 0
-# message('default-private-dns cannot be set to strict or opportunistic when gnutls is disabled. Setting default-private-dns to no.')
-# default_private_dns = 'no'
+# if default_dns_over_tls != 'no' and conf.get('HAVE_GNUTLS') == 0
+# message('default-dns-over-tls cannot be set to strict or opportunistic when gnutls is disabled. Setting default-dns-over-tls to no.')
+# default_dns_over_tls = 'no'
# endif
-# conf.set('DEFAULT_PRIVATE_DNS_MODE',
-# 'PRIVATE_DNS_' + default_private_dns.underscorify().to_upper())
-# substs.set('DEFAULT_PRIVATE_DNS_MODE', default_private_dns)
+# conf.set('DEFAULT_DNS_OVER_TLS_MODE',
+# 'DNS_OVER_TLS_' + default_dns_over_tls.underscorify().to_upper())
+# substs.set('DEFAULT_DNS_OVER_TLS_MODE', default_dns_over_tls)
#
# want_importd = get_option('importd')
# if want_importd != 'false'
@@ -1946,6 +1946,7 @@ executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
+executable('elogind-user-runtime-dir',
user_runtime_dir_sources,
include_directories : includes,
link_with : [libshared, liblogind_core],
@@ -3215,7 +3216,7 @@ status = [
# 'symbolic gateway hostnames: @0@'.format(', '.join(gateway_hostnames)),
#
# 'default DNSSEC mode: @0@'.format(default_dnssec),
-# 'default private DNS mode: @0@'.format(default_private_dns),
+# 'default DNS-over-TLS mode: @0@'.format(default_dns_over_tls),
# 'default cgroup hierarchy: @0@'.format(default_hierarchy),
#endif // 0
'default KillUserProcesses setting: @0@'.format(kill_user_processes)]
diff --git a/meson_options.txt b/meson_options.txt
index 6fe7cf3da..d8160d983 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -247,8 +247,8 @@ option('gshadow', type : 'boolean',
# description : 'default DNSSEC mode',
# choices : ['yes', 'allow-downgrade', 'no'],
# value : 'allow-downgrade')
-# option('default-private-dns', type : 'combo',
-# description : 'default private DNS mode',
+# option('default-dns-over-tls', type : 'combo',
+# description : 'default DNS-over-TLS mode',
# choices : ['opportunistic', 'no'],
# value : 'no')
# option('dns-servers', type : 'string',
diff --git a/shell-completion/bash/resolvectl b/shell-completion/bash/resolvectl
index dcacb1269..97e83d2bd 100644
--- a/shell-completion/bash/resolvectl
+++ b/shell-completion/bash/resolvectl
@@ -48,14 +48,14 @@ _resolvectl() {
[LINK]='revert dns domain nta'
[RESOLVE]='llmnr mdns'
[DNSSEC]='dnssec'
- [PRIVATEDNS]='privatedns'
+ [DNSOVERTLS]='dnsovertls'
[STANDALONE]='statistics reset-statistics flush-caches reset-server-features'
)
local -A ARGS=(
[FAMILY]='tcp udp sctp'
[RESOLVE]='yes no resolve'
[DNSSEC]='yes no allow-downgrade'
- [PRIVATEDNS]='no opportunistic'
+ [DNSOVERTLS]='no opportunistic'
)
local interfaces=$( __get_interfaces )
@@ -111,7 +111,7 @@ _resolvectl() {
comps=""
fi
- elif __contains_word "$verb" ${VERBS[LINK]} ${VERBS[RESOLVE]} ${VERBS[DNSSEC]} ${VERBS[PRIVATEDNS]}; then
+ elif __contains_word "$verb" ${VERBS[LINK]} ${VERBS[RESOLVE]} ${VERBS[DNSSEC]} ${VERBS[DNSOVERTLS]}; then
for ((i++; i < COMP_CWORD; i++)); do
if __contains_word "${COMP_WORDS[i]}" $interfaces &&
! __contains_word "${COMP_WORDS[i-1]}" ${OPTS[ARG]}; then
@@ -155,10 +155,10 @@ _resolvectl() {
comps=''
fi
- elif __contains_word "$verb" ${VERBS[PRIVATEDNS]}; then
+ elif __contains_word "$verb" ${VERBS[DNSOVERTLS]}; then
name=
for ((i++; i < COMP_CWORD; i++)); do
- if __contains_word "${COMP_WORDS[i]}" ${ARGS[PRIVATEDNS]} &&
+ if __contains_word "${COMP_WORDS[i]}" ${ARGS[DNSOVERTLS]} &&
! __contains_word "${COMP_WORDS[i-1]}" ${OPTS[ARG]}; then
name=${COMP_WORDS[i]}
break;
@@ -166,7 +166,7 @@ _resolvectl() {
done
if [[ -z $name ]]; then
- comps=${ARGS[PRIVATEDNS]}
+ comps=${ARGS[DNSOVERTLS]}
else
comps=''
fi