summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am11
-rw-r--r--tmpfiles.d/etc.conf2
2 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cd3a2d747..9f2900cb6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,6 +106,8 @@ udevrulesdir=$(udevlibexecdir)/rules.d
udevhwdbdir=$(udevlibexecdir)/hwdb.d
catalogdir=$(prefix)/lib/systemd/catalog
kernelinstalldir = $(prefix)/lib/kernel/install.d
+factory_etcdir = $(prefix)/share/factory/etc
+factory_pamdir = $(prefix)/share/factory/etc/pam.d
# And these are the special ones for /
rootprefix=@rootprefix@
@@ -1928,6 +1930,14 @@ INSTALL_DIRS += \
endif
# ------------------------------------------------------------------------------
+dist_factory_etc_DATA = \
+ factory/etc/nsswitch.conf
+
+dist_factory_pam_DATA = \
+ factory/etc/pam.d/system-auth \
+ factory/etc/pam.d/other
+
+# ------------------------------------------------------------------------------
if ENABLE_FIRSTBOOT
systemd_firstboot_SOURCES = \
src/firstboot/firstboot.c
@@ -1951,7 +1961,6 @@ EXTRA_DIST += \
SYSINIT_TARGET_WANTS += \
systemd-firstboot.service
-
endif
# ------------------------------------------------------------------------------
diff --git a/tmpfiles.d/etc.conf b/tmpfiles.d/etc.conf
index e809dff2a..b23272cb2 100644
--- a/tmpfiles.d/etc.conf
+++ b/tmpfiles.d/etc.conf
@@ -11,3 +11,5 @@ L /etc/os-release - - - - ../usr/lib/os-release
L /etc/localtime - - - - ../usr/share/zoneinfo/UTC
L+ /etc/mtab - - - - ../proc/self/mounts
L /etc/resolv.conf - - - - ../run/systemd/resolve/resolv.conf
+C /etc/nsswitch.conf - - - -
+C /etc/pam.d - - - -