summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile.am10
-rw-r--r--src/test/test-path.c272
-rw-r--r--test/path-changed.path8
l---------test/path-changed.service1
-rw-r--r--test/path-directorynotempty.path8
l---------test/path-directorynotempty.service1
-rw-r--r--test/path-exists.path8
l---------test/path-exists.service1
-rw-r--r--test/path-existsglob.path8
l---------test/path-existsglob.service1
-rw-r--r--test/path-makedirectory.path10
l---------test/path-makedirectory.service1
-rw-r--r--test/path-modified.path8
l---------test/path-modified.service1
-rw-r--r--test/path-mycustomunit.service6
-rw-r--r--test/path-service.service6
-rw-r--r--test/path-unit.path9
18 files changed, 360 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index 4c66564c4..f1174e755 100644
--- a/.gitignore
+++ b/.gitignore
@@ -213,6 +213,7 @@
/test-network
/test-network-tables
/test-ns
+/test-path
/test-path-util
/test-prioq
/test-ratelimit
diff --git a/Makefile.am b/Makefile.am
index 461ffa944..698a7b0f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1321,6 +1321,7 @@ tests += \
test-env-replace \
test-strbuf \
test-strv \
+ test-path \
test-path-util \
test-strxcpyx \
test-unit-name \
@@ -1809,6 +1810,15 @@ test_path_util_SOURCES = \
test_path_util_LDADD = \
libsystemd-shared.la
+test_path_SOURCES = \
+ src/test/test-path.c
+
+test_path_CFLAGS = \
+ $(AM_CFLAGS)
+
+test_path_LDADD = \
+ libsystemd-core.la
+
test_strxcpyx_SOURCES = \
src/test/test-strxcpyx.c
diff --git a/src/test/test-path.c b/src/test/test-path.c
new file mode 100644
index 000000000..29b187a42
--- /dev/null
+++ b/src/test/test-path.c
@@ -0,0 +1,272 @@
+/***
+ This file is part of systemd.
+
+ Copyright 2014 Ronny Chevalier
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+#include <stdio.h>
+#include <stdbool.h>
+
+#include "unit.h"
+#include "manager.h"
+#include "util.h"
+#include "macro.h"
+#include "strv.h"
+#include "mkdir.h"
+
+typedef void (*test_function_t)(Manager *m);
+
+static int setup_test(Manager **m) {
+ char **tests_path = STRV_MAKE("exists", "existsglobFOOBAR", "changed", "modified", "unit",
+ "directorynotempty", "makedirectory");
+ char **test_path;
+ Manager *tmp;
+ int r;
+
+ assert_se(m);
+
+ r = manager_new(SYSTEMD_USER, true, &tmp);
+ if (IN_SET(r, -EPERM, -EACCES, -EADDRINUSE, -EHOSTDOWN, -ENOENT)) {
+ printf("Skipping test: manager_new: %s", strerror(-r));
+ return -EXIT_TEST_SKIP;
+ }
+ assert_se(r >= 0);
+ assert_se(manager_startup(tmp, NULL, NULL) >= 0);
+
+ STRV_FOREACH(test_path, tests_path) {
+ rm_rf_dangerous(strappenda("/tmp/test-path_", *test_path), false, true, false);
+ }
+
+ *m = tmp;
+
+ return 0;
+}
+
+static void shutdown_test(Manager *m) {
+ assert_se(m);
+
+ manager_free(m);
+}
+
+static void check_stop_unlink(Manager *m, Unit *unit, const char *test_path, const char *service_name) {
+ _cleanup_free_ char *tmp = NULL;
+ Unit *service_unit = NULL;
+ Service *service = NULL;
+ usec_t ts;
+ usec_t timeout = 2 * USEC_PER_SEC;
+
+ assert_se(m);
+ assert_se(unit);
+ assert_se(test_path);
+
+ if (!service_name) {
+ assert_se(tmp = strreplace(unit->id, ".path", ".service"));
+ service_unit = manager_get_unit(m, tmp);
+ } else
+ service_unit = manager_get_unit(m, service_name);
+ assert_se(service_unit);
+ service = SERVICE(service_unit);
+
+ ts = now(CLOCK_MONOTONIC);
+ /* We proces events until the service related to the path has been successfully started */
+ while(service->result != SERVICE_SUCCESS || service->state != SERVICE_START) {
+ usec_t n;
+ int r;
+
+ r = sd_event_run(m->event, 100 * USEC_PER_MSEC);
+ assert_se(r >= 0);
+
+ printf("%s: state = %s; result = %s \n",
+ service_unit->id,
+ service_state_to_string(service->state),
+ service_result_to_string(service->result));
+
+
+ /* But we timeout if the service has not been started in the allocated time */
+ n = now(CLOCK_MONOTONIC);
+ if (ts + timeout < n) {
+ log_error("Test timeout when testing %s", unit->id);
+ exit(EXIT_FAILURE);
+ }
+ }
+
+ assert_se(UNIT_VTABLE(unit)->stop(unit) >= 0);
+ assert_se(UNIT_VTABLE(service_unit)->stop(service_unit) >= 0);
+ rm_rf_dangerous(test_path, false, true, false);
+}
+
+static void test_path_exists(Manager *m) {
+ const char *test_path = "/tmp/test-path_exists";
+ Unit *unit = NULL;
+
+ assert_se(m);
+
+ assert_se(manager_load_unit(m, "path-exists.path", NULL, NULL, &unit) >= 0);
+ assert_se(UNIT_VTABLE(unit)->start(unit) >= 0);
+
+ assert_se(touch(test_path) >= 0);
+
+ check_stop_unlink(m, unit, test_path, NULL);
+}
+
+static void test_path_existsglob(Manager *m) {
+ const char *test_path = "/tmp/test-path_existsglobFOOBAR";
+ Unit *unit = NULL;
+
+ assert_se(m);
+ assert_se(manager_load_unit(m, "path-existsglob.path", NULL, NULL, &unit) >= 0);
+ assert_se(UNIT_VTABLE(unit)->start(unit) >= 0);
+
+ assert_se(touch(test_path) >= 0);
+
+ check_stop_unlink(m, unit, test_path, NULL);
+}
+
+static void test_path_changed(Manager *m) {
+ const char *test_path = "/tmp/test-path_changed";
+ FILE *f;
+ Unit *unit = NULL;
+
+ assert_se(m);
+
+ assert_se(touch(test_path) >= 0);
+
+ assert_se(manager_load_unit(m, "path-changed.path", NULL, NULL, &unit) >= 0);
+ assert_se(UNIT_VTABLE(unit)->start(unit) >= 0);
+
+ f = fopen(test_path, "w");
+ assert_se(f);
+ fclose(f);
+
+ check_stop_unlink(m, unit, test_path, NULL);
+}
+
+static void test_path_modified(Manager *m) {
+ _cleanup_fclose_ FILE *f = NULL;
+ const char *test_path = "/tmp/test-path_modified";
+ Unit *unit = NULL;
+
+ assert_se(m);
+
+ assert_se(touch(test_path) >= 0);
+
+ assert_se(manager_load_unit(m, "path-modified.path", NULL, NULL, &unit) >= 0);
+ assert_se(UNIT_VTABLE(unit)->start(unit) >= 0);
+
+ f = fopen(test_path, "w");
+ assert_se(f);
+ fputs("test", f);
+
+ check_stop_unlink(m, unit, test_path, NULL);
+}
+
+static void test_path_unit(Manager *m) {
+ const char *test_path = "/tmp/test-path_unit";
+ Unit *unit = NULL;
+
+ assert_se(m);
+
+ assert_se(manager_load_unit(m, "path-unit.path", NULL, NULL, &unit) >= 0);
+ assert_se(UNIT_VTABLE(unit)->start(unit) >= 0);
+
+ assert_se(touch(test_path) >= 0);
+
+ check_stop_unlink(m, unit, test_path, "path-mycustomunit.service");
+}
+
+static void test_path_directorynotempty(Manager *m) {
+ const char *test_path = "/tmp/test-path_directorynotempty/";
+ Unit *unit = NULL;
+
+ assert_se(m);
+
+ assert_se(access(test_path, F_OK) < 0);
+
+ assert_se(manager_load_unit(m, "path-directorynotempty.path", NULL, NULL, &unit) >= 0);
+ assert_se(UNIT_VTABLE(unit)->start(unit) >= 0);
+
+ /* MakeDirectory default to no */
+ assert_se(access(test_path, F_OK) < 0);
+
+ assert_se(mkdir_p(test_path, 0755) >= 0);
+ assert_se(touch(strappenda(test_path, "test_file")) >= 0);
+
+ check_stop_unlink(m, unit, test_path, NULL);
+}
+
+static void test_path_makedirectory_directorymode(Manager *m) {
+ const char *test_path = "/tmp/test-path_makedirectory/";
+ Unit *unit = NULL;
+ struct stat s;
+
+ assert_se(m);
+
+ assert_se(access(test_path, F_OK) < 0);
+
+ assert_se(manager_load_unit(m, "path-makedirectory.path", NULL, NULL, &unit) >= 0);
+ assert_se(UNIT_VTABLE(unit)->start(unit) >= 0);
+
+ /* Check if the directory has been created */
+ assert_se(access(test_path, F_OK) >= 0);
+
+ /* Check the mode we specified with DirectoryMode=0744 */
+ assert_se(stat(test_path, &s) >= 0);
+ assert_se((s.st_mode & S_IRWXU) == 0700);
+ assert_se((s.st_mode & S_IRWXG) == 0040);
+ assert_se((s.st_mode & S_IRWXO) == 0004);
+
+ assert_se(UNIT_VTABLE(unit)->stop(unit) >= 0);
+ rm_rf_dangerous(test_path, false, true, false);
+}
+
+int main(int argc, char *argv[]) {
+ test_function_t tests[] = {
+ test_path_exists,
+ test_path_existsglob,
+ test_path_changed,
+ test_path_modified,
+ test_path_unit,
+ test_path_directorynotempty,
+ test_path_makedirectory_directorymode,
+ NULL,
+ };
+ test_function_t *test = NULL;
+ Manager *m = NULL;
+
+ log_parse_environment();
+ log_open();
+
+ /* It is needed otherwise cgroup creation fails */
+ if (getuid() != 0)
+ return EXIT_TEST_SKIP;
+
+ assert_se(set_unit_path(TEST_DIR ":") >= 0);
+
+ for (test = tests; test && *test; test++) {
+ int r;
+
+ /* We create a clean environment for each test */
+ r = setup_test(&m);
+ if (r < 0)
+ return -r;
+
+ (*test)(m);
+
+ shutdown_test(m);
+ }
+
+ return 0;
+}
diff --git a/test/path-changed.path b/test/path-changed.path
new file mode 100644
index 000000000..e58bdd925
--- /dev/null
+++ b/test/path-changed.path
@@ -0,0 +1,8 @@
+[Unit]
+Description=Test PathChanged
+
+[Path]
+PathChanged=/tmp/test-path_changed
+
+[Install]
+WantedBy=multi-user.target
diff --git a/test/path-changed.service b/test/path-changed.service
new file mode 120000
index 000000000..8bdf17883
--- /dev/null
+++ b/test/path-changed.service
@@ -0,0 +1 @@
+path-service.service \ No newline at end of file
diff --git a/test/path-directorynotempty.path b/test/path-directorynotempty.path
new file mode 100644
index 000000000..17e599fc0
--- /dev/null
+++ b/test/path-directorynotempty.path
@@ -0,0 +1,8 @@
+[Unit]
+Description=Test DirectoryNotEmpty
+
+[Path]
+DirectoryNotEmpty=/tmp/test-path_directorynotempty/
+
+[Install]
+WantedBy=multi-user.target
diff --git a/test/path-directorynotempty.service b/test/path-directorynotempty.service
new file mode 120000
index 000000000..8bdf17883
--- /dev/null
+++ b/test/path-directorynotempty.service
@@ -0,0 +1 @@
+path-service.service \ No newline at end of file
diff --git a/test/path-exists.path b/test/path-exists.path
new file mode 100644
index 000000000..c4c9105af
--- /dev/null
+++ b/test/path-exists.path
@@ -0,0 +1,8 @@
+[Unit]
+Description=Test PathExists
+
+[Path]
+PathExists=/tmp/test-path_exists
+
+[Install]
+WantedBy=multi-user.target
diff --git a/test/path-exists.service b/test/path-exists.service
new file mode 120000
index 000000000..8bdf17883
--- /dev/null
+++ b/test/path-exists.service
@@ -0,0 +1 @@
+path-service.service \ No newline at end of file
diff --git a/test/path-existsglob.path b/test/path-existsglob.path
new file mode 100644
index 000000000..a05859960
--- /dev/null
+++ b/test/path-existsglob.path
@@ -0,0 +1,8 @@
+[Unit]
+Description=Test PathExistsGlob
+
+[Path]
+PathExistsGlob=/tmp/test-path_existsglob*
+
+[Install]
+WantedBy=multi-user.target
diff --git a/test/path-existsglob.service b/test/path-existsglob.service
new file mode 120000
index 000000000..8bdf17883
--- /dev/null
+++ b/test/path-existsglob.service
@@ -0,0 +1 @@
+path-service.service \ No newline at end of file
diff --git a/test/path-makedirectory.path b/test/path-makedirectory.path
new file mode 100644
index 000000000..9408479c0
--- /dev/null
+++ b/test/path-makedirectory.path
@@ -0,0 +1,10 @@
+[Unit]
+Description=Test MakeDirectory & DirectoryMode
+
+[Path]
+DirectoryNotEmpty=/tmp/test-path_makedirectory/
+MakeDirectory=yes
+DirectoryMode=0744
+
+[Install]
+WantedBy=multi-user.target
diff --git a/test/path-makedirectory.service b/test/path-makedirectory.service
new file mode 120000
index 000000000..8bdf17883
--- /dev/null
+++ b/test/path-makedirectory.service
@@ -0,0 +1 @@
+path-service.service \ No newline at end of file
diff --git a/test/path-modified.path b/test/path-modified.path
new file mode 100644
index 000000000..18363227b
--- /dev/null
+++ b/test/path-modified.path
@@ -0,0 +1,8 @@
+[Unit]
+Description=Test PathModified
+
+[Path]
+PathModified=/tmp/test-path_modified
+
+[Install]
+WantedBy=multi-user.target
diff --git a/test/path-modified.service b/test/path-modified.service
new file mode 120000
index 000000000..8bdf17883
--- /dev/null
+++ b/test/path-modified.service
@@ -0,0 +1 @@
+path-service.service \ No newline at end of file
diff --git a/test/path-mycustomunit.service b/test/path-mycustomunit.service
new file mode 100644
index 000000000..172ac0d0d
--- /dev/null
+++ b/test/path-mycustomunit.service
@@ -0,0 +1,6 @@
+[Unit]
+Description=Service Test Path Unit=
+
+[Service]
+ExecStart=/bin/true
+Type=oneshot
diff --git a/test/path-service.service b/test/path-service.service
new file mode 100644
index 000000000..f8499ec61
--- /dev/null
+++ b/test/path-service.service
@@ -0,0 +1,6 @@
+[Unit]
+Description=Service Test for Path units
+
+[Service]
+ExecStart=/bin/true
+Type=oneshot
diff --git a/test/path-unit.path b/test/path-unit.path
new file mode 100644
index 000000000..95e572d6d
--- /dev/null
+++ b/test/path-unit.path
@@ -0,0 +1,9 @@
+[Unit]
+Description=Test Path Unit=
+
+[Path]
+PathExists=/tmp/test-path_unit
+Unit=path-mycustomunit.service
+
+[Install]
+WantedBy=multi-user.target