summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am14
-rw-r--r--src/libelogind/libelogind.pc.in2
2 files changed, 14 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2305caff6..bf9082428 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,7 @@ PKTTYAGENT=$(bindir)/pkttyagent
# Our own, non-special dirs
pkgsysconfdir=$(sysconfdir)/elogind
-pkgincludedir=$(includedir)/elogind
+pkgincludedir=$(includedir)/elogind/systemd
udevrulesdir=@udevrulesdir@
udevbindir=@udevbindir@
udevlibexecdir=$(udevbindir)
@@ -625,6 +625,18 @@ pkginclude_HEADERS += \
src/systemd/sd-id128.h \
src/systemd/_sd-common.h
+header-install-hook:
+ $(MKDIR_P) $(DESTDIR)/$(pkgincludedir)
+ cd $(DESTDIR)/$(includedir)/elogind && \
+ for hdr in $(notdir $(pkginclude_HEADERS)) ; do \
+ $(LN_S) systemd/$$hdr $$hdr ; \
+ done
+
+header-uninstall-hook:
+ m -f $(DESTDIR)/$(includedir)/elogind/*.h
+
+INSTALL_EXEC_HOOKS += header-install-hook
+UNINSTALL_EXEC_HOOKS += header-uninstall-hook
lib_LTLIBRARIES += \
libelogind.la
diff --git a/src/libelogind/libelogind.pc.in b/src/libelogind/libelogind.pc.in
index 17a92b130..0b0fd87dd 100644
--- a/src/libelogind/libelogind.pc.in
+++ b/src/libelogind/libelogind.pc.in
@@ -8,7 +8,7 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
libdir=@libdir@
-includedir=@includedir@
+includedir=@includedir@/elogind
Name: elogind
Description: elogind Library