summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile-man.am15
-rw-r--r--Makefile.am1
-rw-r--r--man/logind.service.xml119
-rw-r--r--man/sd_is_fifo.xml13
-rw-r--r--src/libelogind/sd-daemon/sd-daemon.c3
-rw-r--r--src/libsystemd/libsystemd.sym2
-rw-r--r--src/systemd/sd-daemon.h2
7 files changed, 134 insertions, 21 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index d862b3bba..c481f8342 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -22,7 +22,6 @@ MANPAGES_ALIAS += \
man/logind.8 \
man/sd_id128_from_string.3 \
man/sd_id128_get_boot.3 \
- man/sd_is_mq.3 \
man/sd_is_socket.3 \
man/sd_is_socket_inet.3 \
man/sd_is_socket_unix.3 \
@@ -35,7 +34,6 @@ MANPAGES_ALIAS += \
man/logind.8: man/logind.service.8
man/sd_id128_from_string.3: man/sd_id128_to_string.3
man/sd_id128_get_boot.3: man/sd_id128_get_machine.3
-man/sd_is_mq.3: man/sd_is_fifo.3
man/sd_is_socket.3: man/sd_is_fifo.3
man/sd_is_socket_inet.3: man/sd_is_fifo.3
man/sd_is_socket_unix.3: man/sd_is_fifo.3
@@ -54,9 +52,6 @@ man/sd_id128_from_string.html: man/sd_id128_to_string.html
man/sd_id128_get_boot.html: man/sd_id128_get_machine.html
$(html-alias)
-man/sd_is_mq.html: man/sd_is_fifo.html
- $(html-alias)
-
man/sd_is_socket.html: man/sd_is_fifo.html
$(html-alias)
@@ -194,6 +189,15 @@ man/sd_session_is_remote.html: man/sd_session_is_active.html
endif
+if HAVE_PYTHON
+MANPAGES += \
+ man/elogind.index.7
+MANPAGES_ALIAS += \
+ #
+
+
+endif
+
# Really, do not edit this file.
EXTRA_DIST += \
@@ -201,6 +205,7 @@ EXTRA_DIST += \
man/libelogind-pkgconfig.xml \
man/loginctl.xml \
man/logind.conf.xml \
+ man/logind.service.xml \
man/logind.xml \
man/pam_elogind.xml \
man/sd_get_seats.xml \
diff --git a/Makefile.am b/Makefile.am
index 6a19521b0..4cee67380 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -374,7 +374,6 @@ libbasic_la_LIBADD = \
$(SELINUX_LIBS) \
$(CAP_LIBS) \
-ldl \
- -lrt \
-lm
# -----------------------------------------------------------------------------
diff --git a/man/logind.service.xml b/man/logind.service.xml
new file mode 100644
index 000000000..404c45632
--- /dev/null
+++ b/man/logind.service.xml
@@ -0,0 +1,119 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of elogind.
+
+ Copyright 2010 Lennart Poettering
+
+ elogind is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ elogind is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with elogind; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="logind.service">
+
+ <refentryinfo>
+ <title>logind.service</title>
+ <productname>elogind</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>logind.service</refentrytitle>
+ <manvolnum>8</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>logind.service</refname>
+ <refname>logind</refname>
+ <refpurpose>Login manager</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <para><filename>logind.service</filename></para>
+ <para><filename>/usr/lib/systemd/logind</filename></para>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><command>logind</command> is a system service that
+ manages user logins. It is responsible for:</para>
+
+ <itemizedlist>
+ <listitem><para>Keeping track of users and sessions, their
+ processes and their idle state</para></listitem>
+
+ <listitem><para>Providing PolicyKit-based access for users to
+ operations such as system shutdown or sleep</para></listitem>
+
+ <listitem><para>Implementing a shutdown/sleep inhibition logic
+ for applications</para></listitem>
+
+ <listitem><para>Handling of power/sleep hardware
+ keys</para></listitem>
+
+ <listitem><para>Multi-seat management</para></listitem>
+
+ <listitem><para>Session switch management</para></listitem>
+
+ <listitem><para>Device access management for
+ users</para></listitem>
+
+ <listitem><para>Automatic spawning of text logins (gettys) on
+ virtual console activation and user runtime directory
+ management</para></listitem>
+ </itemizedlist>
+
+ <para>User sessions are registered in logind via the
+ <citerefentry><refentrytitle>pam_elogind</refentrytitle><manvolnum>8</manvolnum></citerefentry>
+ PAM module.</para>
+
+ <para>See
+ <citerefentry><refentrytitle>logind.conf</refentrytitle><manvolnum>5</manvolnum></citerefentry>
+ for information about the configuration of this service.</para>
+
+ <para>See <ulink
+ url="http://www.freedesktop.org/wiki/Software/systemd/multiseat">Multi-Seat
+ on Linux</ulink> for an introduction into basic concepts of logind
+ such as users, sessions and seats.</para>
+
+ <para>See the <ulink
+ url="http://www.freedesktop.org/wiki/Software/systemd/logind">
+ logind D-Bus API Documentation</ulink> for information about the
+ APIs <filename>logind</filename> provides.</para>
+
+ <para>For more information on the inhibition logic see the <ulink
+ url="http://www.freedesktop.org/wiki/Software/systemd/inhibit">Inhibitor
+ Lock Developer Documentation</ulink>.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+ <para>
+ <citerefentry><refentrytitle>loginctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>logind.conf</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>pam_elogind</refentrytitle><manvolnum>8</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>
diff --git a/man/sd_is_fifo.xml b/man/sd_is_fifo.xml
index 83c204d0c..f5ca8580e 100644
--- a/man/sd_is_fifo.xml
+++ b/man/sd_is_fifo.xml
@@ -48,7 +48,6 @@
<refname>sd_is_socket</refname>
<refname>sd_is_socket_inet</refname>
<refname>sd_is_socket_unix</refname>
- <refname>sd_is_mq</refname>
<refname>sd_is_special</refname>
<refpurpose>Check the type of a file descriptor</refpurpose>
</refnamediv>
@@ -90,12 +89,6 @@
</funcprototype>
<funcprototype>
- <funcdef>int <function>sd_is_mq</function></funcdef>
- <paramdef>int <parameter>fd</parameter></paramdef>
- <paramdef>const char *<parameter>path</parameter></paramdef>
- </funcprototype>
-
- <funcprototype>
<funcdef>int <function>sd_is_special</function></funcdef>
<paramdef>int <parameter>fd</parameter></paramdef>
<paramdef>const char *<parameter>path</parameter></paramdef>
@@ -151,12 +144,6 @@
<parameter>path</parameter> to the initial 0 byte of the socket
address.</para>
- <para><function>sd_is_mq()</function> may be called to check
- whether the specified file descriptor refers to a POSIX message
- queue. If the <parameter>path</parameter> parameter is not
- <constant>NULL</constant>, it is checked whether the message queue
- is bound to the specified name.</para>
-
<para><function>sd_is_special()</function> may be called to check
whether the specified file descriptor refers to a special file. If
the <parameter>path</parameter> parameter is not
diff --git a/src/libelogind/sd-daemon/sd-daemon.c b/src/libelogind/sd-daemon/sd-daemon.c
index d230a48da..9a696cd22 100644
--- a/src/libelogind/sd-daemon/sd-daemon.c
+++ b/src/libelogind/sd-daemon/sd-daemon.c
@@ -307,6 +307,8 @@ _public_ int sd_is_socket_unix(int fd, int type, int listening, const char *path
return 1;
}
+/// UNNEEDED by elogind
+#if 0
_public_ int sd_is_mq(int fd, const char *path) {
struct mq_attr attr;
@@ -337,6 +339,7 @@ _public_ int sd_is_mq(int fd, const char *path) {
return 1;
}
+#endif // 0
_public_ int sd_pid_notify_with_fds(pid_t pid, int unset_environment, const char *state, const int *fds, unsigned n_fds) {
union sockaddr_union sockaddr = {
diff --git a/src/libsystemd/libsystemd.sym b/src/libsystemd/libsystemd.sym
index d5ad127bc..b4e52dd37 100644
--- a/src/libsystemd/libsystemd.sym
+++ b/src/libsystemd/libsystemd.sym
@@ -66,7 +66,7 @@ global:
/* sd-daemon */
sd_booted;
sd_is_fifo;
- sd_is_mq;
+ /* sd_is_mq; */
sd_is_socket;
sd_is_socket_inet;
sd_is_socket_unix;
diff --git a/src/systemd/sd-daemon.h b/src/systemd/sd-daemon.h
index 861dc8f1f..1f093f3ca 100644
--- a/src/systemd/sd-daemon.h
+++ b/src/systemd/sd-daemon.h
@@ -154,7 +154,7 @@ int sd_is_socket_unix(int fd, int type, int listening, const char *path, size_t
See sd_is_mq(3) for more information.
*/
-int sd_is_mq(int fd, const char *path);
+/// UNNEEDED int sd_is_mq(int fd, const char *path);
/*
Informs systemd about changed daemon state. This takes a number of