summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore4
-rw-r--r--Makefile.am56
-rw-r--r--TODO4
-rw-r--r--man/journalctl.xml (renamed from man/systemd-journalctl.xml)11
-rw-r--r--man/loginctl.xml (renamed from man/systemd-loginctl.xml)11
-rw-r--r--man/systemctl.xml7
-rw-r--r--man/systemd-journald.conf.xml2
-rw-r--r--man/systemd-logind.conf.xml2
-rw-r--r--man/systemd.exec.xml3
9 files changed, 69 insertions, 31 deletions
diff --git a/.gitignore b/.gitignore
index 3b69eb46f..8f30c5e0d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,7 +4,7 @@
/systemd-cat
/systemd-rc-local-generator
/libsystemd-id128.pc
-systemd-journalctl
+journalctl
systemd-journald
test-id128
test-journal
@@ -14,7 +14,7 @@ org.freedesktop.locale1.xml
libsystemd-daemon.pc
libsystemd-login.pc
test-login
-systemd-loginctl
+loginctl
systemd-localed
systemd-timedated
org.freedesktop.timedate1.xml
diff --git a/Makefile.am b/Makefile.am
index 32ec0e04c..99ad9c030 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -690,16 +690,22 @@ MANPAGES = \
man/systemd-cat.1 \
man/systemd-machine-id-setup.1 \
man/systemd-journald.conf.5 \
- man/systemd-journalctl.1
+ man/journalctl.1
MANPAGES_ALIAS = \
man/reboot.8 \
man/poweroff.8 \
- man/init.1
+ man/init.1 \
+ man/systemd-systemctl.1 \
+ man/systemd-loginctl.1 \
+ man/systemd-journalctl.1
man/reboot.8: man/halt.8
man/poweroff.8: man/halt.8
man/init.1: man/systemd.1
+man/systemd-systemctl.1: man/systemctl.1
+man/systemd-loginctl.1: man/loginctl.1
+man/systemd-journalctl.1: man/journalctl.1
XML_FILES = \
${patsubst %.1,%.xml,${patsubst %.3,%.xml,${patsubst %.5,%.xml,${patsubst %.7,%.xml,${patsubst %.8,%.xml,$(MANPAGES)}}}}}
@@ -979,6 +985,14 @@ systemctl_LDADD = \
libsystemd-id128.la \
$(DBUS_LIBS)
+systemctl-install-hook:
+ cd $(DESTDIR)$(rootbindir) && \
+ rm -f systemd-systemctl && \
+ $(LN_S) systemctl systemd-systemctl
+
+INSTALL_EXEC_HOOKS += \
+ systemctl-install-hook
+
systemd_notify_SOURCES = \
src/notify.c \
src/readahead/sd-readahead.c
@@ -1207,26 +1221,34 @@ systemd_cat_LDADD = \
libsystemd-basic.la \
libsystemd-journal.la
-systemd_journalctl_SOURCES = \
+journalctl_SOURCES = \
src/journal/journalctl.c \
src/pager.c \
src/logs-show.c
-systemd_journalctl_LDADD = \
+journalctl_LDADD = \
libsystemd-basic.la \
libsystemd-journal.la \
libsystemd-id128.la
if HAVE_XZ
-systemd_journalctl_SOURCES += \
+journalctl_SOURCES += \
src/journal/compress.c
-systemd_journalctl_CFLAGS = \
+journalctl_CFLAGS = \
$(AM_CFLAGS) \
$(XZ_CFLAGS)
-systemd_journalctl_LDADD += \
+journalctl_LDADD += \
$(XZ_LIBS)
endif
+journalctl-install-hook:
+ cd $(DESTDIR)$(rootbindir) && \
+ rm -f systemd-journalctl && \
+ $(LN_S) journalctl systemd-journalctl
+
+INSTALL_EXEC_HOOKS += \
+ journalctl-install-hook
+
test_journal_SOURCES = \
src/journal/test-journal.c \
src/journal/sd-journal.c \
@@ -1313,7 +1335,7 @@ rootlibexec_PROGRAMS += \
systemd-journald
rootbin_PROGRAMS += \
- systemd-journalctl
+ journalctl
bin_PROGRAMS += \
systemd-cat
@@ -1813,7 +1835,7 @@ rootlibexec_PROGRAMS += \
systemd-logind \
systemd-user-sessions
-systemd_loginctl_SOURCES = \
+loginctl_SOURCES = \
src/login/loginctl.c \
src/login/sysfs-show.c \
src/dbus-common.c \
@@ -1821,18 +1843,26 @@ systemd_loginctl_SOURCES = \
src/cgroup-util.c \
src/pager.c
-systemd_loginctl_CFLAGS = \
+loginctl_CFLAGS = \
$(AM_CFLAGS) \
$(DBUS_CFLAGS) \
$(UDEV_CFLAGS)
-systemd_loginctl_LDADD = \
+loginctl_LDADD = \
libsystemd-basic.la \
$(DBUS_LIBS) \
$(UDEV_LIBS)
rootbin_PROGRAMS += \
- systemd-loginctl
+ loginctl
+
+loginctl-install-hook:
+ cd $(DESTDIR)$(rootbindir) && \
+ rm -f systemd-loginctl && \
+ $(LN_S) loginctl systemd-loginctl
+
+INSTALL_EXEC_HOOKS += \
+ loginctl-install-hook
test_login_SOURCES = \
src/login/test-login.c
@@ -1997,7 +2027,7 @@ nodist_udevrules_DATA += \
MANPAGES += \
man/systemd-logind.conf.5 \
man/sd-login.7 \
- man/systemd-loginctl.1 \
+ man/loginctl.1 \
man/sd_login_monitor_new.3 \
man/sd_pid_get_session.3 \
man/sd_uid_get_state.3 \
diff --git a/TODO b/TODO
index 176c2a742..7f19c3adc 100644
--- a/TODO
+++ b/TODO
@@ -18,6 +18,10 @@ Bugfixes:
Features:
+* ensure that logind sets the syslog facility to AUTH when logging
+
+* when a service has the same env var set twice we actually store it twice and return that in systemctl show -p... We should only show the last setting
+
* add man page documenting all kernel cmdline options, including stuff like fsck.mode=
* show getty in container mode, not sulogin
diff --git a/man/systemd-journalctl.xml b/man/journalctl.xml
index 1441ecaca..c4d2a7e0e 100644
--- a/man/systemd-journalctl.xml
+++ b/man/journalctl.xml
@@ -21,10 +21,10 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="systemd-journalctl">
+<refentry id="journalctl">
<refentryinfo>
- <title>systemd-journalctl</title>
+ <title>journalctl</title>
<productname>systemd</productname>
<authorgroup>
@@ -38,25 +38,26 @@
</refentryinfo>
<refmeta>
- <refentrytitle>systemd-journalctl</refentrytitle>
+ <refentrytitle>journalctl</refentrytitle>
<manvolnum>1</manvolnum>
</refmeta>
<refnamediv>
+ <refname>journalctl</refname>
<refname>systemd-journalctl</refname>
<refpurpose>Query the systemd journal</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
- <command>systemd-journalctl <arg choice="opt" rep="repeat">OPTIONS</arg> <arg choice="opt">MATCH</arg></command>
+ <command>journalctl <arg choice="opt" rep="repeat">OPTIONS</arg> <arg choice="opt">MATCH</arg></command>
</cmdsynopsis>
</refsynopsisdiv>
<refsect1>
<title>Description</title>
- <para><command>systemd-journalctl</command> may be
+ <para><command>journalctl</command> may be
used to query the contents of the
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>
journal.</para>
diff --git a/man/systemd-loginctl.xml b/man/loginctl.xml
index 6a282769a..be72cc331 100644
--- a/man/systemd-loginctl.xml
+++ b/man/loginctl.xml
@@ -21,10 +21,10 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="systemd-loginctl">
+<refentry id="loginctl">
<refentryinfo>
- <title>systemd-loginctl</title>
+ <title>loginctl</title>
<productname>systemd</productname>
<authorgroup>
@@ -38,25 +38,26 @@
</refentryinfo>
<refmeta>
- <refentrytitle>systemd-loginctl</refentrytitle>
+ <refentrytitle>loginctl</refentrytitle>
<manvolnum>1</manvolnum>
</refmeta>
<refnamediv>
+ <refname>loginctl</refname>
<refname>systemd-loginctl</refname>
<refpurpose>Control the systemd login manager</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
- <command>systemd-loginctl <arg choice="opt" rep="repeat">OPTIONS</arg> <arg choice="req">COMMAND</arg> <arg choice="opt" rep="repeat">NAME</arg></command>
+ <command>loginctl <arg choice="opt" rep="repeat">OPTIONS</arg> <arg choice="req">COMMAND</arg> <arg choice="opt" rep="repeat">NAME</arg></command>
</cmdsynopsis>
</refsynopsisdiv>
<refsect1>
<title>Description</title>
- <para><command>systemd-loginctl</command> may be used to
+ <para><command>loginctl</command> may be used to
introspect and control the state of the
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>
login manager.</para>
diff --git a/man/systemctl.xml b/man/systemctl.xml
index c467ed8bf..ffe016400 100644
--- a/man/systemctl.xml
+++ b/man/systemctl.xml
@@ -44,6 +44,7 @@
<refnamediv>
<refname>systemctl</refname>
+ <refname>systemd-systemctl</refname>
<refpurpose>Control the systemd system and service manager</refpurpose>
</refnamediv>
@@ -448,7 +449,7 @@
formatting of the journal entries that
are shown. For the available choices
see
- <citerefentry><refentrytitle>systemd-journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>. Defaults
+ <citerefentry><refentrytitle>journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>. Defaults
to
<literal>short</literal>.</para></listitem>
</varlistentry>
@@ -1179,8 +1180,8 @@
<para>
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemadm</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
- <citerefentry><refentrytitle>systemd-journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
- <citerefentry><refentrytitle>systemd-loginctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>loginctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemd.unit</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemd.special</refentrytitle><manvolnum>7</manvolnum></citerefentry>,
<citerefentry><refentrytitle>wall</refentrytitle><manvolnum>1</manvolnum></citerefentry>
diff --git a/man/systemd-journald.conf.xml b/man/systemd-journald.conf.xml
index f3cd4db26..37dae68b3 100644
--- a/man/systemd-journald.conf.xml
+++ b/man/systemd-journald.conf.xml
@@ -246,7 +246,7 @@
<title>See Also</title>
<para>
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
- <citerefentry><refentrytitle>systemd-journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemd.conf</refentrytitle><manvolnum>5</manvolnum></citerefentry>
</para>
</refsect1>
diff --git a/man/systemd-logind.conf.xml b/man/systemd-logind.conf.xml
index 4b0281503..27c11c290 100644
--- a/man/systemd-logind.conf.xml
+++ b/man/systemd-logind.conf.xml
@@ -167,7 +167,7 @@
<title>See Also</title>
<para>
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
- <citerefentry><refentrytitle>systemd-loginctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>loginctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemd.conf</refentrytitle><manvolnum>5</manvolnum></citerefentry>
</para>
</refsect1>
diff --git a/man/systemd.exec.xml b/man/systemd.exec.xml
index ac0f89fb8..e6f49c9fd 100644
--- a/man/systemd.exec.xml
+++ b/man/systemd.exec.xml
@@ -397,7 +397,7 @@
<citerefentry><refentrytitle>dmesg</refentrytitle><manvolnum>1</manvolnum></citerefentry>. <option>journal</option>
connects it with the journal which is
accessible via
- <citerefentry><refentrytitle>systemd-journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+ <citerefentry><refentrytitle>journalctl</refentrytitle><manvolnum>1</manvolnum></citerefentry>
(Note that everything that is written
to syslog or kmsg is implicitly stored
in the journal as well, those options
@@ -1094,6 +1094,7 @@
<para>
<citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemctl</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>journalctl</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemd.unit</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemd.service</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
<citerefentry><refentrytitle>systemd.socket</refentrytitle><manvolnum>5</manvolnum></citerefentry>,