summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am11
-rw-r--r--units/user/.gitignore1
-rw-r--r--units/user/systemd-consoled.service.in15
3 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3119a95da..e52db1793 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -250,6 +250,7 @@ SOCKETS_TARGET_WANTS =
BUSNAMES_TARGET_WANTS =
TIMERS_TARGET_WANTS =
USER_SOCKETS_TARGET_WANTS =
+USER_DEFAULT_TARGET_WANTS =
USER_BUSNAMES_TARGET_WANTS =
SYSTEM_UNIT_ALIASES =
@@ -270,6 +271,7 @@ install-target-wants-hook:
what="$(TIMERS_TARGET_WANTS)" && wants=timers.target && dir=$(systemunitdir) && $(add-wants)
what="$(SLICES_TARGET_WANTS)" && wants=slices.target && dir=$(systemunitdir) && $(add-wants)
what="$(USER_SOCKETS_TARGET_WANTS)" && wants=sockets.target && dir=$(userunitdir) && $(add-wants)
+ what="$(USER_DEFAULT_TARGET_WANTS)" && wants=default.target && dir=$(userunitdir) && $(add-wants)
install-busnames-target-wants-hook:
what="$(BUSNAMES_TARGET_WANTS)" && wants=busnames.target && dir=$(systemunitdir) && $(add-wants)
@@ -3035,6 +3037,15 @@ noinst_PROGRAMS += \
dist_pkgdata_DATA += \
src/libsystemd-terminal/unifont-glyph-array.bin
+nodist_userunit_DATA += \
+ units/user/systemd-consoled.service
+
+USER_DEFAULT_TARGET_WANTS += \
+ systemd-consoled.service
+
+EXTRA_DIST += \
+ units/user/systemd-consoled.service.in
+
tests += \
test-term-page \
test-term-parser \
diff --git a/units/user/.gitignore b/units/user/.gitignore
index 6aa54754c..c91ed626c 100644
--- a/units/user/.gitignore
+++ b/units/user/.gitignore
@@ -1,2 +1,3 @@
/systemd-exit.service
/systemd-bus-proxyd@.service
+/systemd-consoled.service
diff --git a/units/user/systemd-consoled.service.in b/units/user/systemd-consoled.service.in
new file mode 100644
index 000000000..fd7938aa8
--- /dev/null
+++ b/units/user/systemd-consoled.service.in
@@ -0,0 +1,15 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Console Manager and Terminal Emulator
+
+[Service]
+Type=notify
+Restart=always
+RestartSec=0
+ExecStart=@rootlibexecdir@/systemd-consoled