summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meson.build7
-rw-r--r--src/basic/missing.h2
2 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3e97f57f3..0d096d847 100644
--- a/meson.build
+++ b/meson.build
@@ -509,6 +509,13 @@ foreach decl : ['char16_t',
conf.set10('HAVE_' + decl.underscorify().to_upper(), have)
endforeach
+conf.set10('HAVE_STRUCT_STATX_IN_SYS_STAT_H', cc.sizeof('struct statx', prefix : '''
+#include <sys/stat.h>
+''', args : '-D_GNU_SOURCE') > 0)
+conf.set10('HAVE_STRUCT_STATX_IN_LINUX_STAT_H', cc.sizeof('struct statx', prefix : '''
+#include <linux/stat.h>
+''', args : '-D_GNU_SOURCE') > 0)
+
foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
['IN6_ADDR_GEN_MODE_STABLE_PRIVACY', 'linux/if_link.h'],
['IFLA_VRF_TABLE', 'linux/if_link.h'],
diff --git a/src/basic/missing.h b/src/basic/missing.h
index fb1478548..9be48eef8 100644
--- a/src/basic/missing.h
+++ b/src/basic/missing.h
@@ -1371,7 +1371,7 @@ struct fib_rule_uid_range {
#define PF_KTHREAD 0x00200000
#endif
-#if ! HAVE_STRUCT_STATX
+#if !HAVE_STRUCT_STATX_IN_SYS_STAT_H && !HAVE_STRUCT_STATX_IN_LINUX_STAT_H
struct statx_timestamp {
int64_t tv_sec;
uint32_t tv_nsec;