summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meson.build1
-rw-r--r--meson_options.txt1
-rw-r--r--src/core/meson.build176
3 files changed, 89 insertions, 89 deletions
diff --git a/meson.build b/meson.build
index dea963aa8..ecc72c0fe 100644
--- a/meson.build
+++ b/meson.build
@@ -2474,7 +2474,6 @@ executable('elogind-cgroups-agent',
# public_programs += [exe]
# endif
#endif // 0
-
############################################################
foreach tuple : tests
diff --git a/meson_options.txt b/meson_options.txt
index d4d944806..441d22749 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -7,7 +7,6 @@ option('rootlibdir', type : 'string',
option('rootprefix', type : 'string',
description : '''override the root prefix''')
#if 0 /// UNNEEDED by elogind
-# Note: See meson.build why we use precompiler masks
# option('link-udev-shared', type : 'boolean',
# description : 'link systemd-udev and its helpers to libsystemd-shared.so')
#
diff --git a/src/core/meson.build b/src/core/meson.build
index a9d4c3d73..2790e431f 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -1,115 +1,117 @@
#if 0 /// elogind has only two of the parts here in it...
# libcore_la_sources = '''
-# unit.c
-# unit.h
-# unit-printf.c
-# unit-printf.h
-# job.c
-# job.h
-# manager.c
-# manager.h
-# transaction.c
-# transaction.h
-# load-fragment.c
-# load-fragment.h
-# service.c
-# service.h
-# socket.c
-# socket.h
-# target.c
-# target.h
-# device.c
-# device.h
-# mount.c
-# mount.h
+# audit-fd.c
+# audit-fd.h
# automount.c
# automount.h
-# swap.c
-# swap.h
-# timer.c
-# timer.h
-# path.c
-# path.h
-# slice.c
-# slice.h
-# scope.c
-# scope.h
-# load-dropin.c
-# load-dropin.h
-# execute.c
-# execute.h
-# dynamic-user.c
-# dynamic-user.h
-# kill.c
-# kill.h
-# dbus.c
-# dbus.h
-# dbus-manager.c
-# dbus-manager.h
-# dbus-unit.c
-# dbus-unit.h
+# cgroup.c
+# cgroup.h
+# dbus-automount.c
+# dbus-automount.h
+# dbus-cgroup.c
+# dbus-cgroup.h
+# dbus-device.c
+# dbus-device.h
+# dbus-execute.c
+# dbus-execute.h
# dbus-job.c
# dbus-job.h
+# dbus-kill.c
+# dbus-kill.h
+# dbus-manager.c
+# dbus-manager.h
+# dbus-mount.c
+# dbus-mount.h
+# dbus-path.c
+# dbus-path.h
+# dbus-scope.c
+# dbus-scope.h
# dbus-service.c
# dbus-service.h
+# dbus-slice.c
+# dbus-slice.h
# dbus-socket.c
# dbus-socket.h
-# dbus-target.c
-# dbus-target.h
-# dbus-device.c
-# dbus-device.h
-# dbus-mount.c
-# dbus-mount.h
-# dbus-automount.c
-# dbus-automount.h
# dbus-swap.c
# dbus-swap.h
+# dbus-target.c
+# dbus-target.h
# dbus-timer.c
# dbus-timer.h
-# dbus-path.c
-# dbus-path.h
-# dbus-slice.c
-# dbus-slice.h
-# dbus-scope.c
-# dbus-scope.h
-# dbus-execute.c
-# dbus-execute.h
-# dbus-kill.c
-# dbus-kill.h
-# dbus-cgroup.c
-# dbus-cgroup.h
-# cgroup.c
-# cgroup.h
-# selinux-access.c
-# selinux-access.h
-# selinux-setup.c
-# selinux-setup.h
-# smack-setup.c
-# smack-setup.h
+# dbus-unit.c
+# dbus-unit.h
+# dbus.c
+# dbus.h
+# device.c
+# device.h
+# dynamic-user.c
+# dynamic-user.h
+# emergency-action.c
+# emergency-action.h
+# execute.c
+# execute.h
+# hostname-setup.c
+# hostname-setup.h
# ima-setup.c
# ima-setup.h
-# locale-setup.h
+# ip-address-access.c
+# ip-address-access.h
+# job.c
+# job.h
+# kill.c
+# kill.h
+# killall.c
+# killall.h
+# kmod-setup.c
+# kmod-setup.h
+# load-dropin.c
+# load-dropin.h
+# load-fragment.c
+# load-fragment.h
# locale-setup.c
-# hostname-setup.c
-# hostname-setup.h
+# locale-setup.h
+# loopback-setup.c
+# loopback-setup.h
# machine-id-setup.c
# machine-id-setup.h
+# manager.c
+# manager.h
# mount-setup.c
# mount-setup.h
-# kmod-setup.c
-# kmod-setup.h
-# loopback-setup.h
-# loopback-setup.c
+# mount.c
+# mount.h
# namespace.c
# namespace.h
-# killall.h
-# killall.c
-# audit-fd.c
-# audit-fd.h
+# path.c
+# path.h
+# scope.c
+# scope.h
+# selinux-access.c
+# selinux-access.h
+# selinux-setup.c
+# selinux-setup.h
+# service.c
+# service.h
# show-status.c
# show-status.h
-# emergency-action.c
-# emergency-action.h
+# slice.c
+# slice.h
+# smack-setup.c
+# smack-setup.h
+# socket.c
+# socket.h
+# swap.c
+# swap.h
+# target.c
+# target.h
+# timer.c
+# timer.h
+# transaction.c
+# transaction.h
+# unit-printf.c
+# unit-printf.h
+# unit.c
+# unit.h
# '''.split()
#else
libcore_la_sources = files('''