summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am2
-rw-r--r--man/elogind.xml3
-rw-r--r--man/loginctl.xml3
-rw-r--r--src/basic/missing.h1
-rw-r--r--src/core/cgroup.h1
-rw-r--r--src/login/loginctl.c2
-rw-r--r--src/login/logind-action.c1
-rw-r--r--src/login/logind.c13
8 files changed, 10 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index bd4230c0d..d6e1bd856 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,7 @@ SUBDIRS = . po
.PRECIOUS: $(TEST_SUITE_LOG) Makefile
LIBELOGIND_CURRENT=16
-LIBELOGIND_REVISION=0
+LIBELOGIND_REVISION=2
LIBELOGIND_AGE=16
# Dirs of external packages
diff --git a/man/elogind.xml b/man/elogind.xml
index 08a37cd54..140249fc2 100644
--- a/man/elogind.xml
+++ b/man/elogind.xml
@@ -21,7 +21,8 @@
along with elogind; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="elogind">
+<refentry id="elogind"
+ xmlns:xi="http://www.w3.org/2001/XInclude">
<refentryinfo>
<title>elogind</title>
diff --git a/man/loginctl.xml b/man/loginctl.xml
index 46f1a990f..0f638c260 100644
--- a/man/loginctl.xml
+++ b/man/loginctl.xml
@@ -21,7 +21,8 @@
along with elogind; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="loginctl" xmlns:xi="http://www.w3.org/2001/XInclude">
+<refentry id="loginctl"
+ xmlns:xi="http://www.w3.org/2001/XInclude">
<refentryinfo>
<title>loginctl</title>
diff --git a/src/basic/missing.h b/src/basic/missing.h
index 322cb5695..f2a0e1d8b 100644
--- a/src/basic/missing.h
+++ b/src/basic/missing.h
@@ -442,7 +442,6 @@ struct btrfs_ioctl_quota_ctl_args {
#endif
#endif // 0
-
#ifndef CGROUP_SUPER_MAGIC
#define CGROUP_SUPER_MAGIC 0x27e0eb
#endif
diff --git a/src/core/cgroup.h b/src/core/cgroup.h
index 3b6299f2f..c3b87bfc5 100644
--- a/src/core/cgroup.h
+++ b/src/core/cgroup.h
@@ -179,7 +179,6 @@ bool unit_cgroup_delegate(Unit *u);
int unit_notify_cgroup_empty(Unit *u);
#endif // 0
-
int manager_notify_cgroup_empty(Manager *m, const char *group);
#if 0 /// UNNEEDED by elogind
diff --git a/src/login/loginctl.c b/src/login/loginctl.c
index 07dbcd5ad..2eeaf0b9e 100644
--- a/src/login/loginctl.c
+++ b/src/login/loginctl.c
@@ -1630,7 +1630,6 @@ static int loginctl_main(int argc, char *argv[], sd_bus *bus) {
if ((argc == optind) && (ACTION_CANCEL_SHUTDOWN == arg_action))
return elogind_cancel_shutdown(bus);
#endif // 1
-
return dispatch_verb(argc, argv, verbs, bus);
}
@@ -1670,6 +1669,5 @@ finish:
#if 1 /// elogind has some own cleanups to do
elogind_cleanup();
#endif // 1
-
return r < 0 ? EXIT_FAILURE : EXIT_SUCCESS;
}
diff --git a/src/login/logind-action.c b/src/login/logind-action.c
index 6b1b64229..82c061d62 100644
--- a/src/login/logind-action.c
+++ b/src/login/logind-action.c
@@ -38,7 +38,6 @@
#include "sd-messages.h"
#include "strv.h"
-
int manager_handle_action(
Manager *m,
InhibitWhat inhibit_key,
diff --git a/src/login/logind.c b/src/login/logind.c
index 046caf7be..77a11bbfe 100644
--- a/src/login/logind.c
+++ b/src/login/logind.c
@@ -52,7 +52,6 @@
static void manager_free(Manager *m);
static void manager_reset_config(Manager *m) {
-
#if 0 /// elogind does not support autospawning of vts
m->n_autovts = 6;
m->reserve_vt = 6;
@@ -83,7 +82,6 @@ static void manager_reset_config(Manager *m) {
m->kill_only_users = strv_free(m->kill_only_users);
m->kill_exclude_users = strv_free(m->kill_exclude_users);
-
#if 1 /// elogind needs an Add-On for sleep configuration
elogind_manager_reset_config(m);
#endif // 1
@@ -122,7 +120,6 @@ static Manager *manager_new(void) {
if (r < 0)
goto fail;
#endif // 1
-
m->udev = udev_new();
if (!m->udev)
goto fail;
@@ -214,7 +211,6 @@ static void manager_free(Manager *m) {
#if 0 /// elogind does not support autospawning of vts
safe_close(m->reserve_vt_fd);
#endif // 0
-
#if 1 /// elogind has to free its own data
elogind_manager_free(m);
#endif // 1
@@ -732,12 +728,14 @@ static int manager_connect_bus(Manager *m) {
if (r < 0)
return log_error_errno(r, "Failed to attach bus to event loop: %m");
-#if 1 /// elogind has to setup its release agent
+#if 0 /// elogind has to setup its release agent
+ return 0;
+#else
elogind_bus_setup_system(m);
r = elogind_setup_cgroups_agent(m);
-#endif // 1
return r;
+#endif // 0
}
static int manager_vt_switch(sd_event_source *src, const struct signalfd_siginfo *si, void *data) {
@@ -1287,8 +1285,7 @@ finish:
"STOPPING=1\n"
"STATUS=Shutting down...");
- if (m)
- manager_free(m);
+ manager_free(m);
return r < 0 ? EXIT_FAILURE : EXIT_SUCCESS;
}