summaryrefslogtreecommitdiff
path: root/Makefile-man.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile-man.am')
-rw-r--r--Makefile-man.am29
1 files changed, 17 insertions, 12 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index bd5306e67..2b3fa95e7 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -23,7 +23,6 @@ MANPAGES += \
man/machine-id.5 \
man/machine-info.5 \
man/os-release.5 \
- man/runlevel.8 \
man/sd-daemon.3 \
man/sd-id128.3 \
man/sd-journal.3 \
@@ -93,7 +92,6 @@ MANPAGES += \
man/systemd-tty-ask-password-agent.1 \
man/systemd-udevd.service.8 \
man/systemd-update-done.service.8 \
- man/systemd-update-utmp.service.8 \
man/systemd.1 \
man/systemd.automount.5 \
man/systemd.device.5 \
@@ -227,8 +225,6 @@ MANPAGES_ALIAS += \
man/systemd-udevd-kernel.socket.8 \
man/systemd-udevd.8 \
man/systemd-update-done.8 \
- man/systemd-update-utmp-runlevel.service.8 \
- man/systemd-update-utmp.8 \
man/systemd-user.conf.5
man/SD_ALERT.3: man/sd-daemon.3
man/SD_CRIT.3: man/sd-daemon.3
@@ -334,8 +330,6 @@ man/systemd-udevd-control.socket.8: man/systemd-udevd.service.8
man/systemd-udevd-kernel.socket.8: man/systemd-udevd.service.8
man/systemd-udevd.8: man/systemd-udevd.service.8
man/systemd-update-done.8: man/systemd-update-done.service.8
-man/systemd-update-utmp-runlevel.service.8: man/systemd-update-utmp.service.8
-man/systemd-update-utmp.8: man/systemd-update-utmp.service.8
man/systemd-user.conf.5: man/systemd-system.conf.5
man/SD_ALERT.html: man/sd-daemon.html
$(html-alias)
@@ -649,12 +643,6 @@ man/systemd-udevd.html: man/systemd-udevd.service.html
man/systemd-update-done.html: man/systemd-update-done.service.html
$(html-alias)
-man/systemd-update-utmp-runlevel.service.html: man/systemd-update-utmp.service.html
- $(html-alias)
-
-man/systemd-update-utmp.html: man/systemd-update-utmp.service.html
- $(html-alias)
-
man/systemd-user.conf.html: man/systemd-system.conf.html
$(html-alias)
@@ -1509,6 +1497,23 @@ MANPAGES_ALIAS += \
endif
+if HAVE_UTMP
+MANPAGES += \
+ man/runlevel.8 \
+ man/systemd-update-utmp.service.8
+MANPAGES_ALIAS += \
+ man/systemd-update-utmp-runlevel.service.8 \
+ man/systemd-update-utmp.8
+man/systemd-update-utmp-runlevel.service.8: man/systemd-update-utmp.service.8
+man/systemd-update-utmp.8: man/systemd-update-utmp.service.8
+man/systemd-update-utmp-runlevel.service.html: man/systemd-update-utmp.service.html
+ $(html-alias)
+
+man/systemd-update-utmp.html: man/systemd-update-utmp.service.html
+ $(html-alias)
+
+endif
+
# Really, do not edit this file.
EXTRA_DIST += \