summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 702513768..f0d80ba74 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -841,6 +841,8 @@ libsystemd_shared_la_SOURCES = \
src/shared/login-shared.h \
src/shared/ring.c \
src/shared/ring.h \
+ src/shared/barrier.c \
+ src/shared/barrier.h \
src/shared/async.c \
src/shared/async.h \
src/shared/eventfd-util.c \
@@ -1251,6 +1253,7 @@ tests += \
test-ellipsize \
test-util \
test-ring \
+ test-barrier \
test-tmpfiles \
test-namespace \
test-date \
@@ -1421,6 +1424,12 @@ test_ring_SOURCES = \
test_ring_LDADD = \
libsystemd-core.la
+test_barrier_SOURCES = \
+ src/test/test-barrier.c
+
+test_barrier_LDADD = \
+ libsystemd-core.la
+
test_tmpfiles_SOURCES = \
src/test/test-tmpfiles.c