summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index fa6fd7d54..513c85265 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -490,8 +490,7 @@ dist_systemunit_DATA = \
units/systemd-udevd-control.socket \
units/systemd-udevd-kernel.socket \
units/system-update.target \
- units/initrd-switch-root.target \
- units/ldconfig.service
+ units/initrd-switch-root.target
nodist_systemunit_DATA = \
units/getty@.service \
@@ -919,6 +918,16 @@ libsystemd_label_la_CFLAGS = \
libsystemd_label_la_LIBADD = \
$(SELINUX_LIBS)
+# -----------------------------------------------------------------------------
+
+if ENABLE_LDCONFIG
+dist_systemunit_DATA += \
+ units/ldconfig.service
+
+SYSINIT_TARGET_WANTS += \
+ ldconfig.service
+endif
+
# ------------------------------------------------------------------------------
if HAVE_SECCOMP
@@ -5789,8 +5798,7 @@ endif
SYSINIT_TARGET_WANTS += \
systemd-update-utmp.service \
- systemd-update-done.service \
- ldconfig.service
+ systemd-update-done.service
LOCAL_FS_TARGET_WANTS += \
systemd-remount-fs.service \