summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e0f5fb20..d50ab3d70 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1102,7 +1102,8 @@ tests += \
test-cgroup-util \
test-prioq \
test-fileio \
- test-time
+ test-time \
+ test-hashmap
EXTRA_DIST += \
test/sched_idle_bad.service \
@@ -1193,6 +1194,15 @@ test_util_CFLAGS = \
test_util_LDADD = \
libsystemd-core.la
+test_hashmap_SOURCES = \
+ src/test/test-hashmap.c
+
+test_hashmap_CFLAGS = \
+ $(AM_CFLAGS)
+
+test_hashmap_LDADD = \
+ libsystemd-core.la
+
test_prioq_SOURCES = \
src/test/test-prioq.c