summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9d35cfced..2ceba5619 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,9 @@ if test "x$enable_extras" = xyes; then
AC_CHECK_HEADER([linux/input.h], [:], AC_MSG_ERROR([kernel headers not found]))
AC_SUBST([INCLUDE_PREFIX], [$(echo '#include <linux/input.h>' | eval $ac_cpp -E - | sed -n '/linux\/input.h/ {s:.*"\(.*\)/linux/input.h".*:\1:; p; q}')])
+
+ AC_CHECK_HEADER([linux/videodev.h], [have_videodev_h=yes], [])
+ AM_CONDITIONAL(HAVE_V4L1, [test "x$have_videodev_h" = "xyes"])
fi
AM_CONDITIONAL([ENABLE_EXTRAS], [test "x$enable_extras" = xyes])