summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
Diffstat (limited to 'man')
-rw-r--r--man/meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/man/meson.build b/man/meson.build
index 8fdb512f6..ea1227f2c 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -178,10 +178,10 @@ man = custom_target(
depends : man_pages,
command : ['echo'])
-html = run_target(
+html = custom_target(
'html',
- depends : html_pages,
output : 'html',
+ depends : html_pages,
command : ['echo'])
#if 0 /// UNNEEDED in elogind
@@ -201,8 +201,9 @@ html = run_target(
############################################################
if git.found()
- run_target(
+ custom_target(
'update-man-rules',
+ output : 'update-man-rules',
# slightly strange syntax because of
# https://github.com/mesonbuild/meson/issues/1643
# and https://github.com/mesonbuild/meson/issues/1512