summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 550d7a674..fdc4f7d79 100644
--- a/meson.build
+++ b/meson.build
@@ -589,6 +589,22 @@ else
conf.set10('HAVE_GETRANDOM', have)
endif
+#if 1 /// elogind shall be usable with non-glibc libc variations
+#####################################################################
+# Find out whether program_invocation[_short]_name is supported
+have_pisn = cc.links('''
+ #define _GNU_SOURCE 1
+ #include <errno.h>
+ int main(void) {
+ if (program_invocation_name && program_invocation_short_name)
+ return 0;
+ return 1;
+ }
+''', name : 'program_invocation[_short]_name test')
+conf.set10('HAVE_PROGRAM_INVOCATION_NAME', have_pisn,
+ description : 'program_invocation[_short]_name is provided by libc')
+
+#endif // 1
#####################################################################
sed = find_program('sed')