summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt306
1 files changed, 306 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
new file mode 100644
index 000000000..3ec87540b
--- /dev/null
+++ b/meson_options.txt
@@ -0,0 +1,306 @@
+# -*- mode: meson -*-
+
+option('split-usr', type : 'boolean', value : false,
+ description : '''assume that /bin, /sbin aren't symlinks into /usr''')
+option('rootlibdir', type : 'string',
+ description : '''[/usr]/lib/x86_64-linux-gnu or such''')
+option('rootprefix', type : 'string',
+ description : '''override the root prefix''')
+#if 0 /// UNNEEDED by elogind
+# Note: See meson.build why we use precompiler masks
+# option('link-udev-shared', type : 'boolean',
+# description : 'link systemd-udev and its helpers to libsystemd-shared.so')
+#
+# option('sysvinit-path', type : 'string', value : '/etc/init.d',
+# description : 'the directory where the SysV init scripts are located')
+# option('sysvrcnd-path', type : 'string', value : '/etc/rc.d',
+# description : 'the base directory for SysV rcN.d directories')
+# option('telinit-path', type : 'string', description : 'path to telinit')
+# option('rc-local', type : 'string',
+# value : '/etc/rc.local')
+# option('halt-local', type : 'string',
+# value : '/usr/sbin/halt.local')
+#
+# option('quotaon-path', type : 'string', description : 'path to quotaon')
+# option('quotacheck-path', type : 'string', description : 'path to quotacheck')
+# option('kill-path', type : 'string', description : 'path to kill')
+# option('kmod-path', type : 'string', description : 'path to kmod')
+#else
+# elogind must have a configurable rootlibexecdir
+option('rootlibexecdir', type : 'string',
+ description : '''override the root libexec directory path''')
+
+# And because elogind depends on external udev, it must be
+# configurable as well.
+option('udevrulesdir', type : 'string',
+ description : '''directory for udev rules files''')
+
+option('udevbindir', type : 'string',
+ description : '''directory for udev binary files''')
+
+# We have no systemd-shutdown binary, so we need 'halt' and 'reboot'
+option('halt-path', type : 'string', description : 'path to halt')
+option('reboot-path', type : 'string', description : 'path to reboot')
+#endif // 0
+option('kexec-path', type : 'string', description : 'path to kexec')
+#if 0 /// UNNEEDED by elogind
+# option('sulogin-path', type : 'string', description : 'path to sulogin')
+# option('mount-path', type : 'string', description : 'path to mount')
+# option('umount-path', type : 'string', description : 'path to umount')
+# option('loadkeys-path', type : 'string', description : 'path to loadkeys')
+# option('setfont-path', type : 'string', description : 'path to setfont')
+#
+# option('debug-shell', type : 'string', value : '/bin/sh',
+# description : 'path to debug shell binary')
+# option('debug-tty', type : 'string', value : '/dev/tty9',
+# description : 'specify the tty device for debug shell')
+# option('debug', type : 'string',
+# description : 'enable extra debugging (hashmap,mmap-cache)')
+#else
+option('debug', type : 'string',
+ description : 'enable extra debugging (elogind,hashmap,mmap-cache)')
+#endif // 0
+
+option('utmp', type : 'boolean',
+ description : 'support for utmp/wtmp log handling')
+#if 0 /// UNNEEDED by elogind
+# option('hibernate', type : 'boolean',
+# description : 'support for hibernation')
+# option('ldconfig', type : 'boolean',
+# description : 'support for dynamic linker cache creation')
+# option('resolve', type : 'boolean',
+# description : 'systemd-resolved stack')
+# option('efi', type : 'boolean',
+# description : 'enable systemd-boot and bootctl')
+# option('tpm', type : 'boolean',
+# description : 'TPM should be used to log events and extend the registers')
+# option('environment-d', type : 'boolean',
+# description : 'support for environment.d')
+# option('binfmt', type : 'boolean',
+# description : 'support for custom binary formats')
+# option('coredump', type : 'boolean',
+# description : 'install the coredump handler')
+# option('logind', type : 'boolean',
+# description : 'install the systemd-logind stack')
+# option('hostnamed', type : 'boolean',
+# description : 'install the systemd-hostnamed stack')
+# option('localed', type : 'boolean',
+# description : 'install the systemd-localed stack')
+# option('machined', type : 'boolean',
+# description : 'install the systemd-machined stack')
+# option('networkd', type : 'boolean',
+# description : 'install the systemd-networkd stack')
+# option('timedated', type : 'boolean',
+# description : 'install the systemd-timedated daemon')
+# option('timesyncd', type : 'boolean',
+# description : 'install the systemd-timesyncd daemon')
+# option('remote', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'support for "journal over the network"')
+# option('myhostname', type : 'boolean',
+# description : 'nss-myhostname support')
+# option('firstboot', type : 'boolean',
+# description : 'support for firstboot mechanism')
+# option('randomseed', type : 'boolean',
+# description : 'support for restoring random seed')
+# option('backlight', type : 'boolean',
+# description : 'support for restoring backlight state')
+# option('vconsole', type : 'boolean',
+# description : 'support for vconsole configuration')
+# option('quotacheck', type : 'boolean',
+# description : 'support for the quotacheck tools')
+# option('sysusers', type : 'boolean',
+# description : 'support for the sysusers configuration')
+# option('tmpfiles', type : 'boolean',
+# description : 'support for tmpfiles.d')
+# option('importd', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'install the systemd-importd daemon')
+# option('hwdb', type : 'boolean',
+# description : 'support for the hardware database')
+# option('rfkill', type : 'boolean',
+# description : 'support for the rfkill tools')
+#endif // 0
+option('man', type : 'combo', choices : ['auto', 'true', 'false'],
+ description : 'build and install man pages')
+option('html', type : 'combo', choices : ['auto', 'true', 'false'],
+ value : 'false',
+ description : 'build and install html pages')
+
+#if 0 /// UNNEEDED by elogind
+# option('certificate-root', type : 'string', value : '/etc/ssl',
+# description : 'the prefix for TLS certificates')
+#endif // 0
+option('dbuspolicydir', type : 'string',
+ description : 'D-Bus policy directory')
+option('dbussessionservicedir', type : 'string',
+ description : 'D-Bus session service directory')
+option('dbussystemservicedir', type : 'string',
+ description : 'D-Bus system service directory')
+option('pkgconfigdatadir', type : 'string', value : 'share/pkgconfig',
+ description : 'directory for ')
+option('pkgconfiglibdir', type : 'string', value : '',
+ description : 'directory for ')
+#if 0 /// UNNEEDED by elogind
+# option('rpmmacrosdir', type : 'string', value : 'lib/rpm/macros.d',
+# description : 'directory for rpm macros ["no" disables]')
+#endif // 0
+option('pamlibdir', type : 'string',
+ description : 'directory for PAM modules')
+option('pamconfdir', type : 'string',
+ description : 'directory for PAM configuration ["no" disables]')
+
+option('fallback-hostname', type : 'string', value : 'localhost',
+ description : 'the hostname used if none configured')
+option('default-hierarchy', type : 'combo',
+ choices : ['legacy', 'hybrid', 'unified'], value : 'hybrid',
+ description : 'default cgroup hierarchy')
+
+#if 0 /// UNNEEDED by elogind
+# option('time-epoch', type : 'string',
+# description : 'time epoch for time clients')
+#else
+option('cgroup-controller', type : 'string',
+ description : 'Name of the cgroup controller to use')
+#endif // 0
+option('system-uid-max', type : 'string',
+ description : 'maximum system UID')
+option('system-gid-max', type : 'string',
+ description : 'maximum system GID')
+option('tty-gid', type : 'string',
+ description : 'the numeric GID of the "tty" group',
+ value : '5')
+#if 0 /// UNNEEDED by elogind
+# option('adm-group', type : 'boolean',
+# description : 'the ACL for adm group should be added')
+# option('wheel-group', type : 'boolean',
+# description : 'the ACL for wheel group should be added')
+# option('nobody-user', type : 'string',
+# description : 'The name of the nobody user (the one with UID 65534)',
+# value : 'nobody')
+# option('nobody-group', type : 'string',
+# description : 'The name of the nobody group (the one with GID 65534)',
+# value : 'nobody')
+# option('dev-kvm-mode', type : 'string', value : '0660',
+# description : '/dev/kvm access mode')
+#endif // 0
+option('default-kill-user-processes', type : 'boolean',
+ description : 'the default value for KillUserProcesses= setting')
+option('gshadow', type : 'boolean',
+ description : 'support for shadow group')
+
+#if 0 /// UNNEEDED by elogind
+# option('default-dnssec', type : 'combo',
+# description : 'default DNSSEC mode',
+# choices : ['yes', 'allow-downgrade', 'no'],
+# value : 'allow-downgrade')
+# option('dns-servers', type : 'string',
+# description : 'space-separated list of default DNS servers',
+# value : '8.8.8.8 8.8.4.4 2001:4860:4860::8888 2001:4860:4860::8844')
+# option('ntp-servers', type : 'string',
+# description : 'space-separated list of default NTP servers',
+# value : 'time1.google.com time2.google.com time3.google.com time4.google.com')
+# option('support-url', type : 'string',
+# description : 'the support URL to show in catalog entries included in systemd',
+# value : 'https://lists.freedesktop.org/mailman/listinfo/systemd-devel')
+# option('www-target', type : 'string',
+# description : 'the address and dir to upload docs too',
+# value : 'www.freedesktop.org:/srv/www.freedesktop.org/www/software/systemd')
+#
+# option('seccomp', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'SECCOMP support')
+#endif // 0
+option('selinux', type : 'combo', choices : ['auto', 'true', 'false'],
+ description : 'SELinux support')
+#if 0 /// UNNEEDED by elogind
+# option('apparmor', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'AppArmor support')
+#endif // 0
+option('smack', type : 'boolean',
+ description : 'SMACK support')
+option('smack-run-label', type : 'string',
+ description : 'run systemd --system itself with a specific SMACK label')
+option('polkit', type : 'combo', choices : ['auto', 'true', 'false'],
+ description : 'PolicyKit support')
+option('ima', type : 'boolean',
+ description : 'IMA support')
+
+option('acl', type : 'combo', choices : ['auto', 'true', 'false'],
+ description : 'libacl support')
+option('audit', type : 'combo', choices : ['auto', 'true', 'false'],
+ description : 'libaudit support')
+#if 0 /// UNNEEDED by elogind
+# option('blkid', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'libblkid support')
+# option('kmod', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'support for loadable modules')
+#endif // 0
+option('pam', type : 'combo', choices : ['auto', 'true', 'false'],
+ description : 'PAM support')
+#if 0 /// UNNEEDED by elogind
+# option('microhttpd', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'libµhttpd support')
+# option('libcryptsetup', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'libcryptsetup support')
+# option('libcurl', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'libcurl support')
+# option('idn', type : 'boolean',
+# description : 'use IDN when printing host names')
+# option('libidn2', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'libidn2 support')
+# option('libidn', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'libidn support')
+# option('nss-systemd', type : 'boolean',
+# description : 'enable nss-systemd')
+# option('libiptc', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'libiptc support')
+# option('qrencode', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'libqrencode support')
+# option('gcrypt', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'gcrypt support')
+# option('gnutls', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'gnutls support')
+# option('elfutils', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'elfutils support')
+# option('zlib', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'zlib compression support')
+# option('bzip2', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'bzip2 compression support')
+# option('xz', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'xz compression support')
+# option('lz4', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'lz4 compression support')
+# option('xkbcommon', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'xkbcommon keymap support')
+#endif // 0
+option('glib', type : 'combo', choices : ['auto', 'true', 'false'],
+ description : 'libglib support (for tests only)')
+option('dbus', type : 'combo', choices : ['auto', 'true', 'false'],
+ description : 'libdbus support (for tests only)')
+
+#if 0 /// UNNEEDED BY elogind
+# option('gnu-efi', type : 'combo', choices : ['auto', 'true', 'false'],
+# description : 'gnu-efi support for sd-boot')
+# option('efi-cc', type : 'string', value : 'gcc',
+# description : 'the compiler to use for EFI modules')
+# option('efi-ld', type : 'string', value : 'ld',
+# description : 'the linker to use for EFI modules')
+# option('efi-libdir', type : 'string',
+# description : 'path to the EFI lib directory')
+# option('efi-ldsdir', type : 'string',
+# description : 'path to the EFI lds directory')
+# option('efi-includedir', type : 'string', value : '/usr/include/efi',
+# description : 'path to the EFI header directory')
+# option('tpm-pcrindex', type : 'string', value : '8',
+# description : 'TPM PCR register number to use')
+#endif // 0
+
+option('bashcompletiondir', type : 'string',
+ description : 'directory for bash completion scripts ["no" disables]')
+option('zshcompletiondir', type : 'string',
+ description : 'directory for zsh completion scripts ["no" disables]')
+
+option('tests', type : 'combo', choices : ['true', 'unsafe'],
+ description : 'enable extra tests with =unsafe')
+option('slow-tests', type : 'boolean', value : 'false',
+ description : 'run the slow tests by default')
+option('install-tests', type : 'boolean', value : 'false',
+ description : 'install test executables')