summaryrefslogtreecommitdiff
path: root/src/login/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/login/meson.build')
-rw-r--r--src/login/meson.build28
1 files changed, 24 insertions, 4 deletions
diff --git a/src/login/meson.build b/src/login/meson.build
index b46576d68..401741e6b 100644
--- a/src/login/meson.build
+++ b/src/login/meson.build
@@ -1,4 +1,22 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
#if 0 /// rename to elogind
+#
# systemd_logind_sources = files('''
# logind.c
# logind.h
@@ -105,11 +123,12 @@ loginctl_sources += files('''
# install_data('org.freedesktop.login1.service',
# install_dir : dbussystemservicedir)
#
-# custom_target(
+# i18n.merge_file(
# 'org.freedesktop.login1.policy',
# input : 'org.freedesktop.login1.policy.in',
# output : 'org.freedesktop.login1.policy',
-# command : intltool_command,
+# po_dir : po_dir,
+# data_dirs : po_dir,
# install : install_polkit,
# install_dir : polkitpolicydir)
#
@@ -156,11 +175,12 @@ logind_service = configure_file(
install_data(logind_service,
install_dir : dbussystemservicedir)
-custom_target(
+i18n.merge_file(
'org.freedesktop.login1.policy',
input : 'org.freedesktop.login1.policy.in',
output : 'org.freedesktop.login1.policy',
- command : intltool_command,
+ po_dir : po_dir,
+ data_dirs : po_dir,
install : install_polkit,
install_dir : polkitpolicydir)