summaryrefslogtreecommitdiff
path: root/src/shared/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/shared/meson.build')
-rw-r--r--src/shared/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index b215e267d..944909c67 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -37,6 +37,7 @@
# dropin.h
# efivars.c
# efivars.h
+# enable-mempool.c
# fdset.c
# fdset.h
# firewall-util.h
@@ -64,6 +65,7 @@
# machine-image.h
# machine-pool.c
# machine-pool.h
+# module-util.h
# nsflags.c
# nsflags.h
# output-mode.c
@@ -112,12 +114,15 @@ shared_sources = '''
clean-ipc.h
conf-parser.c
conf-parser.h
+ enable-mempool.c
musl_missing.c
musl_missing.h
nsflags.c
nsflags.h
output-mode.c
output-mode.h
+ qsort_r_missing.c
+ qsort_r_missing.h
sleep-config.c
sleep-config.h
spawn-polkit-agent.c
@@ -148,6 +153,11 @@ endif
#endif // 0
libshared_name = 'elogind-shared-@0@'.format(meson.project_version())
+#if 0 /// elogind does not play around with kernel modules. Not its job.
+# if conf.get('HAVE_KMOD') == 1
+# shared_sources += files('module-util.c')
+# endif
+#endif // 0
#if 0 /// elogind doesn't need all this
# libshared_deps = [threads,
@@ -157,6 +167,7 @@ libshared_name = 'elogind-shared-@0@'.format(meson.project_version())
# libcryptsetup,
# libgcrypt,
# libiptc,
+# libkmod,
# libseccomp,
# libselinux,
# libidn,