summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/shared/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index 9f4615091..e5cd4d60c 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -65,7 +65,6 @@
# machine-pool.c
# machine-pool.h
# module-util.h
-# module-util.c
# nsflags.c
# nsflags.h
# output-mode.c
@@ -150,6 +149,10 @@ endif
#endif // 0
libshared_name = 'elogind-shared-@0@'.format(meson.project_version())
+if conf.get('HAVE_KMOD') == 1
+ shared_sources += files('module-util.c')
+endif
+
#if 0 /// elogind doesn't need all this
# libshared_deps = [threads,