summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/basic/meson.build1
-rw-r--r--src/basic/set.c62
2 files changed, 0 insertions, 63 deletions
diff --git a/src/basic/meson.build b/src/basic/meson.build
index c4b495e1d..0161aba76 100644
--- a/src/basic/meson.build
+++ b/src/basic/meson.build
@@ -318,7 +318,6 @@ basic_sources = files('''
rm-rf.h
selinux-util.c
selinux-util.h
- set.c
set.h
sigbus.c
sigbus.h
diff --git a/src/basic/set.c b/src/basic/set.c
deleted file mode 100644
index e554e825e..000000000
--- a/src/basic/set.c
+++ /dev/null
@@ -1,62 +0,0 @@
-/* SPDX-License-Identifier: LGPL-2.1+ */
-/***
- This file is part of systemd.
-
- Copyright 2017 Lennart Poettering
-
- systemd is free software; you can redistribute it and/or modify it
- under the terms of the GNU Lesser General Public License as published by
- the Free Software Foundation; either version 2.1 of the License, or
- (at your option) any later version.
-
- systemd is distributed in the hope that it will be useful, but
- WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public License
- along with systemd; If not, see <http://www.gnu.org/licenses/>.
-***/
-
-#include "set.h"
-
-int set_make(Set **ret, const struct hash_ops *hash_ops HASHMAP_DEBUG_PARAMS, void *add, ...) {
- _cleanup_set_free_ Set *s = NULL;
- int r;
-
- assert(ret);
-
- s = set_new(hash_ops HASHMAP_DEBUG_PASS_ARGS);
- if (!s)
- return -ENOMEM;
-
- if (add) {
- va_list ap;
-
- r = set_put(s, add);
- if (r < 0)
- return r;
-
- va_start(ap, add);
-
- for (;;) {
- void *arg = va_arg(ap, void*);
-
- if (!arg)
- break;
-
- r = set_put(s, arg);
- if (r < 0) {
- va_end(ap);
- return r;
- }
- }
-
- va_end(ap);
- }
-
- *ret = s;
- s = NULL;
-
- return 0;
-}