summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <bremner@debian.org>2022-09-24 08:11:42 -0300
committerDavid Bremner <bremner@debian.org>2022-09-24 08:11:42 -0300
commitce4f78d5f742f205d55df3951ff096414eaeff5c (patch)
tree182b91ebfcf605979ca4e5e2b274c4c7001d808a
parentec9678a421ffdb76fda940479e4b14fc491c7bb5 (diff)
Commit Debian 3.0 (quilt) metadatadebian/1.26-1archive/debian/1.26-1
[dgit (10.0) quilt-fixup]
-rw-r--r--debian/patches/debian-changes43
1 files changed, 41 insertions, 2 deletions
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index cc657e2..6ca67d5 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -15,8 +15,29 @@ upload of upstream version 1.2.3, you could use:
`git clone`.)
A single combined diff, containing all the changes, follows.
---- emacs-buttercup-1.24.orig/README.md
-+++ emacs-buttercup-1.24/README.md
+--- emacs-buttercup-1.26.orig/Makefile
++++ emacs-buttercup-1.26/Makefile
+@@ -1,7 +1,7 @@
+ EMACS := emacs
+ VERSION := $(shell sed -ne 's/^;; Version: \(.*\)/\1/p' buttercup.el)
+ ELISP_FILES := $(wildcard *.el)
+-
++TEMP_DIR := $(shell mktemp -d /tmp/butterdocXXXXXX)
+ .PHONY: test compile clean
+
+ all: test
+@@ -12,7 +12,8 @@ check-buttercup test-buttercup: compile
+ ./bin/buttercup -L . tests $(if $(CI),--traceback pretty)
+
+ check-docs test-docs: compile
+- $(EMACS) -batch -L . -l buttercup.el -f buttercup-run-markdown docs/writing-tests.md
++ $(EMACS) -batch -L . --eval "(setq native-compile-target-directory \"${TEMP_DIR}\")" -l buttercup.el -f buttercup-run-markdown docs/writing-tests.md
++ rm -r ${TEMP_DIR}
+
+ compile: $(patsubst %.el,%.elc,$(ELISP_FILES))
+
+--- emacs-buttercup-1.26.orig/README.md
++++ emacs-buttercup-1.26/README.md
@@ -1,10 +1,5 @@
# Buttercup — Behavior-Driven Emacs Lisp Testing
@@ -67,3 +88,21 @@ A single combined diff, containing all the changes, follows.
```Lisp
(describe "A suite"
+--- emacs-buttercup-1.26.orig/bin/buttercup
++++ emacs-buttercup-1.26/bin/buttercup
+@@ -102,8 +102,14 @@ do
+ esac
+ done
+
++tempdir=$(mktemp -d /tmp/buttercupXXXXXX)
++cleanup () {
++ rm -rf $tempdir
++}
++trap EXIT cleanup
++
+ # `--' is needed so that Buttercup options don't get parsed by Emacs itself.
+-exec "$EMACS_BIN" -batch "${EMACS_ARGS[@]}" -l buttercup -f buttercup-run-discover -- "${BUTTERCUP_ARGS[@]}"
++"$EMACS_BIN" -batch "${EMACS_ARGS[@]}" --eval "(setq native-compile-target-directory \"$tmpdir\")" -l buttercup -f buttercup-run-discover -- "${BUTTERCUP_ARGS[@]}"
+
+ # Local Variables:
+ # indent-tabs-mode: nil