summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-05-13 15:43:28 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-05-13 15:43:28 -0700
commit358b9144ee7bb6005ca7e75c26d6d1a6d1090993 (patch)
treed2c4687befa645e86345159117c77bea3bcb7e59 /debian
parent6d91b6c4132c246f858203d4b74b1c348d11a6f9 (diff)
add patch to fix regexp for /usr/bin/buttercup
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/0002-exclude-hidden-files-and-dirs-in-test-root.patch21
-rw-r--r--debian/patches/series1
3 files changed, 30 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 876d21d..1dc9325 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+emacs-buttercup (1.5-2) UNRELEASED; urgency=medium
+
+ * Add patch to fix regexp so that /usr/bin/buttercup ignores tests in
+ hidden directories in the root of a source tree.
+ In particular, this ignores phantom tests found in the .pc/ directory.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Fri, 13 May 2016 15:42:40 -0700
+
emacs-buttercup (1.5-1) unstable; urgency=medium
* New upstream version.
diff --git a/debian/patches/0002-exclude-hidden-files-and-dirs-in-test-root.patch b/debian/patches/0002-exclude-hidden-files-and-dirs-in-test-root.patch
new file mode 100644
index 0000000..df1dbca
--- /dev/null
+++ b/debian/patches/0002-exclude-hidden-files-and-dirs-in-test-root.patch
@@ -0,0 +1,21 @@
+From: Sean Whitton <spwhitton@spwhitton.name>
+Date: Fri, 13 May 2016 14:27:01 -0700
+Subject: exclude hidden files and dirs in test root
+
+---
+ buttercup.el | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/buttercup.el b/buttercup.el
+index cffc182..a38c7c0 100644
+--- a/buttercup.el
++++ b/buttercup.el
+@@ -678,7 +678,7 @@ current directory."
+ (dolist (dir (or dirs '(".")))
+ (dolist (file (directory-files-recursively
+ dir "\\`test-.*\\.el\\'\\|-tests?\\.el\\'"))
+- (when (not (string-match "/\\." (file-relative-name file)))
++ (when (not (string-match "\\(^\\|/\\)\\." (file-relative-name file)))
+ (load file nil t))))
+ (when patterns
+ (let ((suites-or-specs buttercup-suites))
diff --git a/debian/patches/series b/debian/patches/series
index f5305cf..c69443e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
patch-README-for-Debian.diff
+0002-exclude-hidden-files-and-dirs-in-test-root.patch