summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Politz <politza@hochschule-trier.de>2019-01-29 19:15:39 +0100
committerAndreas Politz <politza@hochschule-trier.de>2019-01-29 19:15:39 +0100
commit389730ef0a01e73358d24a37f40fd9db01917f6c (patch)
tree23da2bcef14a155bbf75487559f7c8fb16047d03
parentaf8703139d80be54b6c3077dd3e54ca7f3087043 (diff)
Add byte-compile target
-rw-r--r--Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 91e6b00..55cb555 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,19 @@
+EMACS ?= emacs
+# Handle the mess when inside Emacs.
+unexport INSIDE_EMACS #cask not like this.
+ifeq ($(EMACS), t)
+EMACS = emacs
+endif
+
+emacs = $(EMACS)
all: package
+byte-compile:
+ cask exec $(emacs) --batch -L lisp -f batch-byte-compile *.el
+
package:
cask package
clean:
rm -rf dist
rm -f -- *.elc
-