summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorP. F. Chimento <philip.chimento@gmail.com>2013-10-03 14:08:54 -0700
committerP. F. Chimento <philip.chimento@gmail.com>2013-10-03 14:08:54 -0700
commit949c51de5e283da9d45e45dff7d4c09f3f1e7150 (patch)
tree6f96cb3ce913bac9a257a2aa58b0aeb931156ee7
parentd50ab6145155dd85d54f82a4eb50ed4864cc7f8a (diff)
parentc34c856b07061e23fa22b364f64be50d9121b867 (diff)
Merge pull request #329 from endlessm/issues/321
#321 Put local typelib and lib directories in test environment
-rw-r--r--test/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4730b8b..60a4057 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -50,3 +50,10 @@ AM_JS_LOG_FLAGS = \
$(NULL)
LOG_COMPILER = gtester
AM_LOG_FLAGS = -k --verbose
+
+# Use locally built versions of Endless-0.gir and libraries; this may need to be
+# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
+TESTS_ENVIRONMENT = \
+ export GI_TYPELIB_PATH="$(top_builddir)$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}"; \
+ export LD_LIBRARY_PATH="$(top_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}"; \
+ $(NULL)