summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorP. F. Chimento <philip.chimento@gmail.com>2015-06-19 10:04:03 -0700
committerP. F. Chimento <philip.chimento@gmail.com>2015-06-19 10:04:03 -0700
commit0fcc36fbb265f26a5b246620e095d0250fec635e (patch)
treea10f073ac820aa0b384be563338d9c6a57746698
parentf823c9881033afcf2075439a1b5619c2a0261131 (diff)
parent744c1907d4f30efdaa482da2c2b5dfe7cd210c28 (diff)
Merge pull request #3298 from endlessm/issues/2264-17062015
Update eos-coverage.m4
-rw-r--r--Makefile.am2
-rw-r--r--m4/eos-coverage.m417
2 files changed, 12 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 6948351..9dbd69d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -361,3 +361,5 @@ EOS_COVERAGE_BLACKLIST_PATTERNS = "*test/endless*"
AM_JS_LOG_FLAGS += @EOS_JS_COVERAGE_LOG_FLAGS@
AM_CFLAGS += @EOS_C_COVERAGE_CFLAGS@
AM_LDFLAGS = @EOS_C_COVERAGE_LDFLAGS@
+libwebhelper2private_la_LDFLAGS += @EOS_C_COVERAGE_LDFLAGS@
+wh2extension_la_LDFLAGS += @EOS_C_COVERAGE_LDFLAGS@
diff --git a/m4/eos-coverage.m4 b/m4/eos-coverage.m4
index 766a2d8..c78e725 100644
--- a/m4/eos-coverage.m4
+++ b/m4/eos-coverage.m4
@@ -290,7 +290,7 @@ _eos_js_coverage_data_output_file := $(_eos_js_coverage_trace_path)/coverage.lco
_eos_coverage_outputs += $(_eos_js_coverage_data_output_file)
'
- # This small fragment collects all the paths and add the --coverage-path
+ # This small fragment collects all the paths and add the --coverage-prefix
# prefix to each one, finally adding --coverage-output. This makes the list
# of flags we will pass to gjs to enable coverage reports.
#
@@ -306,16 +306,19 @@ _eos_coverage_outputs += $(_eos_js_coverage_data_output_file)
# The pseudocode for this line looks something like this:
# paths = []
# foreach (p in EOS_JS_COVERAGE_FILES) {
- # if (path.replace(':', ' ').split(' ')[0] == 'resource') {
- # paths.push(p) # resource:// style path, unmodified
- # } else {
- # paths.push(absolute_path_to(p)) # Absolute path
+ # if (path not in EOS_COVERAGE_BLACKLIST_PATTERNS and
+ # path not in [p.withoutprefix("*/") for p in EOS_BLACKLIST_PATTERNS]) {
+ # if (path.replace(':', ' ').split(' ')[0] == 'resource') {
+ # paths.push(p) # resource:// style path, unmodified
+ # } else {
+ # paths.push(absolute_path_to(p)) # Absolute path
+ # }
# }
# }
#
# flags = []
# foreach (p in paths) {
- # flags.push('--coverage-path=' + p)
+ # flags.push('--coverage-prefix=' + p)
# }
#
# $(filter resource,$(firstword $(subst :, ,$(p)))) is a Makefile
@@ -333,7 +336,7 @@ _eos_coverage_outputs += $(_eos_js_coverage_data_output_file)
# cond evalutes to a non-empty string. The documentation on this
# point suggests that conditional operators can be used. This is
# misleading.
- EOS_JS_COVERAGE_LOG_FLAGS='$(addprefix --coverage-path=,$(foreach p,$(EOS_JS_COVERAGE_FILES),$(if $(filter resource,$(firstword $(subst :, ,$(p)))),$(p),$(abspath $(p))))) --coverage-output=$(_eos_js_coverage_trace_path)'
+ EOS_JS_COVERAGE_LOG_FLAGS='$(addprefix --coverage-prefix=,$(foreach p,$(filter-out $(subst */,,$(EOS_COVERAGE_BLACKLIST_PATTERNS)),$(filter-out $(subst *,%,$(EOS_COVERAGE_BLACKLIST_PATTERNS)),$(EOS_JS_COVERAGE_FILES))),$(if $(filter resource,$(firstword $(subst :, ,$(p)))),$(p),$(abspath $(p))))) --coverage-output=$(_eos_js_coverage_trace_path)'
], [
EOS_JS_COVERAGE_RULES=''
])