summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelipe Erias Morandeira <femorandeira@igalia.com>2013-05-22 04:53:34 -0700
committerFelipe Erias Morandeira <femorandeira@igalia.com>2013-05-22 04:53:34 -0700
commit347f7036fdf8d7c1a3db1e5bbcdacaa9b24a1132 (patch)
tree4297fa46a6000b8709388e6813f8e6fdcae03bcb
parentad0a9197169379abe8de5e7affcee38123c51a8b (diff)
parent6316854dac384585ed29a81d88184f788976400c (diff)
Merge pull request #89 from endlessm/issues/86
Ensure that Gtk-Doc and GIR doc are enabled for distributions
-rw-r--r--Makefile.am12
-rw-r--r--configure.ac9
2 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1fcb096..fc08ee0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,6 +29,18 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-gir-doc
CLEANFILES =
DISTCLEANFILES =
+# Make sure that 'make dist' includes documentation
+if CAN_MAKE_DIST
+dist-hook:
+else
+dist-hook:
+ @echo "***"
+ @echo "*** You must configure with --enable-gtk-doc and --enable-gir-doc"
+ @echo "*** to run make dist or make distcheck."
+ @echo "***"
+ @false
+endif
+
# # # LIBRARY # # #
# Main Open Endless SDK library
diff --git a/configure.ac b/configure.ac
index 504ef11..49c3a40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,6 +172,15 @@ AS_IF([test "x$enable_gir_doc" = "xyes"], [
[AC_MSG_ERROR([yelp-build must be installed for --enable-gir-doc])])])
AM_CONDITIONAL([ENABLE_GIR_DOC], [test "x$enable_gir_doc" = "xyes"])
+# For 'make dist' or 'make distcheck', both --enable-gtk-doc and
+# --enable-gir-doc are required
+AC_MSG_CHECKING([whether this configuration allows building distributions])
+can_make_dist=yes
+AM_COND_IF([ENABLE_GTK_DOC], [], [can_make_dist=no])
+AM_COND_IF([ENABLE_GIR_DOC], [], [can_make_dist=no])
+AM_CONDITIONAL([CAN_MAKE_DIST], [test "x$can_make_dist" = "xyes"])
+AC_MSG_RESULT([$can_make_dist])
+
# Required libraries
# ------------------
PKG_CHECK_MODULES([EOS_SDK], [