summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-04-17 13:20:53 -0700
committerPhilip Chimento <philip@endlessm.com>2015-04-17 13:20:53 -0700
commit912da5ca8c4e5689a10fad256b1bf634516c3180 (patch)
tree90fcda7eb77eba9cf8fdefceda9e4add62a2579d
parente9e71b98bbb4d1b31322488a6ef051e022635ad4 (diff)
Lose one level of Makefile includery
Having these tiny included Makefiles is confusing and vulnerable to mistakenly overwriting variables. [endlessm/eos-sdk#3054]
-rw-r--r--test/Makefile.am.inc39
-rw-r--r--test/endless/Makefile.am.inc20
-rw-r--r--test/smoke-tests/Makefile.am.inc20
3 files changed, 35 insertions, 44 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index c18defd..d070b95 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -8,18 +8,49 @@ noinst_PROGRAMS = \
test/smoke-tests/hello \
$(NULL)
-# This variable will be updated in Makefile subdirs (test/endless/Makefile.am.inc)
+test_endless_run_tests_SOURCES = \
+ test/endless/run-tests.c \
+ test/endless/run-tests.h \
+ test/endless/test-init.c \
+ test/endless/test-hello.c \
+ test/endless/test-application.c \
+ test/endless/test-page-manager.c \
+ test/endless/test-window.c \
+ test/endless/test-flexy-grid.c \
+ test/endless/test-custom-container.c \
+ $(NULL)
+test_endless_run_tests_CPPFLAGS = $(TEST_FLAGS)
+test_endless_run_tests_LDADD = $(TEST_LIBS)
+
+test_smoke_tests_hello_SOURCES = test/smoke-tests/hello.c
+test_smoke_tests_hello_CPPFLAGS = $(TEST_FLAGS)
+test_smoke_tests_hello_LDADD = $(TEST_LIBS)
+
+credits_resource_files = \
+ test/smoke-tests/images/test1.jpg \
+ test/smoke-tests/images/test2.jpg \
+ test/smoke-tests/images/test3.jpg \
+ test/smoke-tests/images/attribution.json \
+ $(NULL)
+test/smoke-tests/images/credits.gresource: test/smoke-tests/images/credits.gresource.xml $(credits_resource_files)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/test/smoke-tests/images $<
+dist_noinst_DATA = test/smoke-tests/images/credits.gresource
+CLEANFILES += test/smoke-tests/images/credits.gresource
+EXTRA_DIST += \
+ test/smoke-tests/images/credits.gresource.xml \
+ $(credits_resource_files) \
+ $(NULL)
+
javascript_tests = \
test/tools/eos-application-manifest/testInit.js \
test/webhelper/testTranslate.js \
test/webhelper/testWebActions.js \
test/webhelper/testUpdateFontSize.js \
+ test/endless/testCustomContainer.js \
+ test/endless/testTopbarNavButton.js \
$(NULL)
EXTRA_DIST += $(javascript_tests)
-include test/endless/Makefile.am.inc
-include test/smoke-tests/Makefile.am.inc
-
# Run tests when running 'make check'
TESTS = \
test/endless/run-tests \
diff --git a/test/endless/Makefile.am.inc b/test/endless/Makefile.am.inc
deleted file mode 100644
index 628ad0f..0000000
--- a/test/endless/Makefile.am.inc
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 2013 Endless Mobile, Inc.
-
-test_endless_run_tests_SOURCES = \
- test/endless/run-tests.c \
- test/endless/run-tests.h \
- test/endless/test-init.c \
- test/endless/test-hello.c \
- test/endless/test-application.c \
- test/endless/test-page-manager.c \
- test/endless/test-window.c \
- test/endless/test-flexy-grid.c \
- test/endless/test-custom-container.c \
- $(NULL)
-test_endless_run_tests_CPPFLAGS = $(TEST_FLAGS)
-test_endless_run_tests_LDADD = $(TEST_LIBS)
-
-javascript_tests += \
- test/endless/testCustomContainer.js \
- test/endless/testTopbarNavButton.js \
- $(NULL)
diff --git a/test/smoke-tests/Makefile.am.inc b/test/smoke-tests/Makefile.am.inc
deleted file mode 100644
index 5ee5ac2..0000000
--- a/test/smoke-tests/Makefile.am.inc
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 2013 Endless Mobile, Inc.
-
-test_smoke_tests_hello_SOURCES = test/smoke-tests/hello.c
-test_smoke_tests_hello_CPPFLAGS = $(TEST_FLAGS)
-test_smoke_tests_hello_LDADD = $(TEST_LIBS)
-
-credits_resource_files = \
- test/smoke-tests/images/test1.jpg \
- test/smoke-tests/images/test2.jpg \
- test/smoke-tests/images/test3.jpg \
- test/smoke-tests/images/attribution.json \
- $(NULL)
-test/smoke-tests/images/credits.gresource: test/smoke-tests/images/credits.gresource.xml $(credits_resource_files)
- $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/test/smoke-tests/images $<
-dist_noinst_DATA = test/smoke-tests/images/credits.gresource
-CLEANFILES += test/smoke-tests/images/credits.gresource
-EXTRA_DIST += \
- test/smoke-tests/images/credits.gresource.xml \
- $(credits_resource_files) \
- $(NULL)