summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-03-16 16:54:40 +0000
committerP. F. Chimento <philip.chimento@gmail.com>2018-03-21 12:14:59 -0700
commitd27e9a379ba24d215b73d3bd3c606a3f6833ecd2 (patch)
tree5c1d3d6bfdc596413cd2317710f54016a89eb7ef
parent1fe059365819942330f669d14238b334f4701252 (diff)
Do not link eos-profile with libendless
We don't depend on any specific Endless SDK symbols, and if we link against the SDK library itself we end up enabling the profiling probes; this means we may end up overwriting the profiling data we're trying to open, if by any chance we have `EOS_PROFILE=capture:` in our environment pointing to the profile data we're opening.
-rw-r--r--tools/Makefile.am.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile.am.inc b/tools/Makefile.am.inc
index 145acad..8dce229 100644
--- a/tools/Makefile.am.inc
+++ b/tools/Makefile.am.inc
@@ -71,4 +71,4 @@ eos_profile_CPPFLAGS = \
$(NULL)
eos_profile_CFLAGS = $(AM_CFLAGS)
-eos_profile_LDADD = $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la -lm @EOS_SDK_LIBS@
+eos_profile_LDADD = -lm @EOS_SDK_LIBS@