summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-10-04 14:16:06 -0700
committerPhilip Chimento <philip@endlessm.com>2013-10-04 14:16:06 -0700
commitd4c83acef1574b8f819395b4663ba04bf99daca0 (patch)
treebbb8d9f7a3b7495c14de0abba3a18c7cc8fb129d
parenteaad762acd78c1c7d50f81f8e3fdd0e492e303f3 (diff)
Use ustar format for tarballs
This is necessary because Jenkins' temp directory names will cause file paths longer than 99 characters.
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 057f98e..291fbef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,7 +38,9 @@ dnl AC_CONFIG_SRCDIR([src/hello.c])
# no-portability suppresses warnings about syntax specific to GNU make
# parallel-tests specifies that we use the new parallel-running test harness.
# Unlike serial-tests, this option is accepted by Automake 1.11
-AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 parallel-tests])
+# tar-ustar is required because there may be files whose entire paths exceed
+# 99 characters.
+AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 parallel-tests tar-ustar])
# Avoid spewing garbage over the terminal ('make V=1' to see the garbage)
AM_SILENT_RULES([yes])
# Initialize Libtool; don't build static libraries