summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-04-10 12:17:07 +0100
committerP. F. Chimento <philip.chimento@gmail.com>2013-04-17 17:14:21 +0200
commit408f93ec2327a8647030139a2e6f295e8b2c8de1 (patch)
treec0a796adc7ca6981b8eb0b53e8c21b5101dd2962 /Makefile.am
parent5299f7acf85200a46679334a6bd230d4e2101b7f (diff)
Skeleton build system to build a shared library
Builds a dummy shared library that exports one symbol for testing, eos_hello_sample_function(). [#1]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..544ef5b
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,34 @@
+## Process this file with automake to produce Makefile.in
+
+# Copyright 2013 Endless Mobile, Inc.
+
+## -----------
+## Makefile.am
+## -----------
+## Please keep this file well-commented.
+
+# Our Autoconf macros are kept in the m4/ directory
+ACLOCAL_AMFLAGS = -I m4
+
+# Extra files to distribute in the tarball
+EXTRA_DIST = @EOS_SDK_API_NAME@.pc.in
+
+AM_CFLAGS = @STRICT_CFLAGS@
+
+DISTCLEANFILES =
+
+# # # LIBRARY # # #
+
+# Main Open Endless SDK library
+include $(top_srcdir)/endless/Makefile.am
+
+# Public header files
+endlessincludedir = $(includedir)/@EOS_SDK_API_NAME@
+nobase_endlessinclude_HEADERS = \
+ $(endless_public_installed_headers) \
+ $(endless_private_installed_headers)
+
+# Pkg-config file
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
+DISTCLEANFILES += @EOS_SDK_API_NAME@.pc