summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-09-17 16:47:30 -0700
committerPhilip Chimento <philip@endlessm.com>2013-09-19 14:24:11 -0700
commit4549971954b8b67ed714048730060c9f66f4f56f (patch)
tree8643ba92fb425b0011c4468dbf76915eac989c83 /Makefile.am
parentbf158e4986b6bf5570de2f6bd9de9e4be9b96608 (diff)
Documentation for WebHelper
This adds the infrastructure for autogenerating HTML documentation from a Javascript module using NaturalDocs, and then adds documentation comments to webhelper.js. [endlessm/eos-sdk#302]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b856f5d..013493e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,7 @@ AM_CFLAGS = @STRICT_CFLAGS@
# Make sure to run Gtk-doc tests and build the documentation when doing
# 'make distcheck'
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-gir-doc
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-gir-doc --enable-js-doc
# Generated files that 'make clean' should erase
CLEANFILES =
@@ -35,8 +35,8 @@ dist-hook:
else
dist-hook:
@echo "***"
- @echo "*** You must configure with --enable-gtk-doc and --enable-gir-doc"
- @echo "*** to run make dist or make distcheck."
+ @echo "*** You must configure with --enable-gtk-doc, --enable-gir-doc, and"
+ @echo "*** --enable-js-doc to run make dist or make distcheck."
@echo "***"
@false
endif
@@ -123,6 +123,10 @@ CLEANFILES += \
docs/reference/endless-js/html/*.js
endif
+# # # PURE JAVASCRIPT MODULE DOCUMENTATION # # #
+
+include $(top_srcdir)/docs/reference/webhelper/Makefile.am.inc
+
# # # SECONDARY GRESOURCES # # #
wikipedia_resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/data --generate-dependencies $(srcdir)/data/eos-wikipedia-domain.gresource.xml)