summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-09-06 09:26:02 -0700
committerPhilip Chimento <philip@endlessm.com>2013-09-16 10:30:42 -0700
commit658cb6d84afcb01fc121a04df0d82bbea22c2c25 (patch)
tree77ff4ea8469a036335f56b22c3f6ad422327dc26 /Makefile.am
parente4048bffd4153f7d7bd978f5779caaec8e76a069 (diff)
Unit tests for webhelper
These are tests for the basic functionality and a few fail cases of webhelper, by no means exhaustive. There are a few tests that cannot execute because I do not currently know of any way to catch exceptions that occur inside GObject callbacks. [endlessm/eos-sdk#290]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b2dce68..d8db676 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -165,8 +165,13 @@ include $(top_srcdir)/test/Makefile.am
TESTS = \
test/run-tests \
test/tools/eos-run-test/sanitycheck.js \
+ test/webhelper/testWebActions.js \
+ test/webhelper/testTranslate.js \
$(NULL)
TEST_EXTENSIONS = .js
JS_LOG_COMPILER = tools/eos-run-test
+AM_JS_LOG_FLAGS = \
+ --include-path=$(top_srcdir)/webhelper \
+ $(NULL)
LOG_COMPILER = gtester
AM_LOG_FLAGS = -k --verbose