summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-05-14 15:24:11 -0700
committerPhilip Chimento <philip@endlessm.com>2015-05-20 17:24:52 -0700
commit76d0911286d6f5aeff68ecd558db77be9d55bf07 (patch)
tree9bc55aafffde69cdd4562b9dbeccee6beb67ed25 /Makefile.am
parentd14f575769b82b62f79a26c1cba671af1bc8f94e (diff)
Move webhelper Makefile code into toplevel
In the interest of consolidating the makefiles for readability. [endlessm/eos-sdk#291]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ce67ced..51ac18b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,9 +59,17 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
-# SDK sublibraries
+# # # WEBHELPER LIBRARY # # #
+
+webhelper_sources = webhelper/webhelper.js
+
gjsmodulesdir = $(datadir)/gjs-1.0
-include $(top_srcdir)/webhelper/Makefile.am.inc
+webhelperdir = $(gjsmodulesdir)
+dist_webhelper_DATA = \
+ $(webhelper_sources) \
+ $(NULL)
+
+EOS_JS_COVERAGE_FILES = $(webhelper_sources)
# # # INTROSPECTION FILES # # #