summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2017-04-12 15:24:48 -0700
committerPhilip Chimento <philip@endlessm.com>2017-04-12 16:14:06 -0700
commite54bec3feb08b09de64945f72885c8c37258de60 (patch)
treee86d9c5ff13eaf6b7b5498d68624a413a18b544d /Makefile.am
parent72694e1790f779edc8f8ac163a66af561bf14500 (diff)
build: Remove Webhelper
Webhelper is now in its own repository: https://github.com/endlessm/webhelper https://phabricator.endlessm.com/T16203
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am101
1 files changed, 2 insertions, 99 deletions
diff --git a/Makefile.am b/Makefile.am
index 1491997..9e30ce8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,8 +29,6 @@ AM_CFLAGS = @STRICT_CFLAGS@
AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
--enable-gir-doc \
- --enable-js-doc \
- --enable-webhelper \
$(NULL)
if EOS_ENABLE_COVERAGE
AM_DISTCHECK_CONFIGURE_FLAGS += --enable-coverage --with-coverage-dir=@EOS_COVERAGE_DIR@
@@ -51,36 +49,12 @@ dist-hook::
else
dist-hook::
@echo "***"
- @echo "*** You must configure with --enable-gtk-doc, --enable-gir-doc, and"
- @echo "*** --enable-js-doc to run make dist or make distcheck."
+ @echo "*** You must configure with --enable-gtk-doc and --enable-gir-doc"
+ @echo "*** to run make dist or make distcheck."
@echo "***"
@false
endif
-# # # SUBSTITUTED FILES # # #
-# These files need to be filled in with make variables
-
-subst = $(SED) \
- -e 's,%libexecdir%,$(libexecdir),g' \
- $(NULL)
-
-subst_files =
-if ENABLE_WEBHELPER
-subst_files += \
- webhelper/webhelper_private/config.js \
- $(NULL)
-endif ENABLE_WEBHELPER
-
-$(subst_files): %: %.in Makefile
- $(AM_V_GEN)$(MKDIR_P) $(@D) && \
- rm -f $@ $@.tmp && \
- $(subst) $< > $@.tmp && \
- chmod a-w $@.tmp && \
- mv $@.tmp $@
-
-CLEANFILES += $(subst_files)
-EXTRA_DIST += $(patsubst %,%.in,$(subst_files))
-
# # # LIBRARY # # #
# Main Open Endless SDK library
@@ -97,52 +71,6 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
-# # # WEBHELPER LIBRARY # # #
-
-if ENABLE_WEBHELPER
-
-webhelper_sources = \
- webhelper/webhelper.js \
- webhelper/webhelper2.js \
- $(NULL)
-
-gjsmodulesdir = $(datadir)/gjs-1.0
-webhelperdir = $(gjsmodulesdir)
-webhelper_privatedir = $(webhelperdir)/webhelper_private
-dist_webhelper_DATA = \
- $(webhelper_sources) \
- $(NULL)
-dist_webhelper_private_DATA = \
- webhelper/webhelper_private/config.js \
- $(NULL)
-
-EOS_JS_COVERAGE_FILES += $(webhelper_sources)
-
-## Workaround for https://bugs.webkit.org/show_bug.cgi?id=116672
-## When that is solved, we can eliminate this private library and go back to
-## using pure Javascript in WebHelper.
-lib_LTLIBRARIES += libwebhelper2private.la
-libwebhelper2private_la_SOURCES = \
- webhelper/lib/wh2private.c \
- webhelper/lib/wh2private.h \
- $(NULL)
-libwebhelper2private_la_CPPFLAGS = @WEBHELPER2_PRIVATE_CFLAGS@
-libwebhelper2private_la_LIBADD = @WEBHELPER2_PRIVATE_LIBS@
-libwebhelper2private_la_LDFLAGS = -avoid-version
-
-webhelper2extensionsdir = $(libexecdir)/webhelper2
-webhelper2extensions_LTLIBRARIES = wh2extension.la
-wh2extension_la_SOURCES = \
- webhelper/webextensions/wh2extension.c \
- webhelper/webextensions/wh2jscutil.c \
- webhelper/webextensions/wh2jscutil.h \
- $(NULL)
-wh2extension_la_CPPFLAGS = @WEBHELPER2_EXTENSION_CFLAGS@
-wh2extension_la_LIBADD = @WEBHELPER2_EXTENSION_LIBS@
-wh2extension_la_LDFLAGS = -module -avoid-version -no-undefined
-
-endif ENABLE_WEBHELPER
-
# # # INTROSPECTION FILES # # #
-include $(INTROSPECTION_MAKEFILE)
@@ -169,20 +97,6 @@ Endless_@EOS_SDK_API_VERSION@_gir_FILES = $(introspection_sources)
Endless_@EOS_SDK_API_VERSION@_gir_EXPORT_PACKAGES = @EOS_SDK_API_NAME@
INTROSPECTION_GIRS += Endless-@EOS_SDK_API_VERSION@.gir
-if ENABLE_WEBHELPER
-
-WebHelper2Private-1.0.gir: libwebhelper2private.la
-WebHelper2Private_1_0_gir_INCLUDES = GObject-2.0 GLib-2.0 WebKit2-4.0
-WebHelper2Private_1_0_gir_SCANNERFLAGS = \
- --identifier-prefix=Wh2 \
- --symbol-prefix=wh2 \
- $(NULL)
-WebHelper2Private_1_0_gir_LIBS = libwebhelper2private.la
-WebHelper2Private_1_0_gir_FILES = $(libwebhelper2private_la_SOURCES)
-INTROSPECTION_GIRS += WebHelper2Private-1.0.gir
-
-endif ENABLE_WEBHELPER
-
girdir = $(datadir)/gir-1.0
gir_DATA = $(INTROSPECTION_GIRS)
@@ -365,12 +279,6 @@ nobase_dist_licenses_DATA = licenses/creativecommons/C/CC-BY-2.0.html \
licenses/includes/zero.css \
$(NULL)
-# # # PURE JAVASCRIPT MODULE DOCUMENTATION # # #
-
-if ENABLE_WEBHELPER
-include $(top_srcdir)/docs/reference/webhelper/Makefile.am.inc
-endif ENABLE_WEBHELPER
-
# # # GJS OVERRIDES # # #
include $(top_srcdir)/overrides/Makefile.am.inc
@@ -400,9 +308,4 @@ AM_JS_LOG_FLAGS += @EOS_JS_COVERAGE_LOG_FLAGS@
AM_CFLAGS += @EOS_C_COVERAGE_CFLAGS@
AM_LDFLAGS = @EOS_C_COVERAGE_LDFLAGS@
-if ENABLE_WEBHELPER
-libwebhelper2private_la_LDFLAGS += @EOS_C_COVERAGE_LDFLAGS@
-wh2extension_la_LDFLAGS += @EOS_C_COVERAGE_LDFLAGS@
-endif ENABLE_WEBHELPER
-
clean-local:: clean-coverage