summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-09-04 18:00:01 -0700
committerPhilip Chimento <philip@endlessm.com>2013-09-04 18:00:44 -0700
commit131798705325db7959243adfc1b5a7f96aeb35ce (patch)
tree5eba96212666134c922b7b837f419670b78a7fa9 /Makefile.am
parent2444b1473a980e770b9a85f93ecfb75efd97bbed (diff)
Use Automake's parallel test harness
This gets rid of a long-standing workaround and makes it easier to start using a proper test harness for Javascript unit tests. Unfortunately, it requires a workaround to be able to run gtkdoc-check on the documentation, but the workaround is not too bad. [endlessm/eos-sdk#122]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f7d41d7..740e07e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -156,7 +156,6 @@ m4_DATA = \
include $(top_srcdir)/test/Makefile.am
# Run tests when running 'make check'
-TESTS_ENVIRONMENT = gtester -k -o test-results.xml --verbose
TESTS = test/run-tests
-
-CLEANFILES += test-results.xml
+LOG_COMPILER = gtester
+AM_LOG_FLAGS = -k --verbose