summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-08-27 15:26:30 -0700
committerPhilip Chimento <philip@endlessm.com>2015-08-27 17:16:00 -0700
commit944abb7ea37c2909969890e967521907b982435d (patch)
tree3dfb4b403c7ec5a856285b6cbac6c55296b7aa5c /Makefile.am
parent165d53146c1e411e0cb20df68298b0a0dcd464b7 (diff)
Pass --enable-coverage on to make distcheck
Instead of enforcing this in eos-coverage.m4, the package should opt in to this itself. The new AM_CONDITIONAL makes this easy. [endlessm/eos-sdk#3303]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 61a528f..9805505 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,9 @@ AM_CFLAGS = @STRICT_CFLAGS@
# Make sure to run Gtk-doc tests and build the documentation when doing
# 'make distcheck'
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-gir-doc --enable-js-doc
+if EOS_ENABLE_COVERAGE
+AM_DISTCHECK_CONFIGURE_FLAGS += --enable-coverage --with-coverage-dir=@EOS_COVERAGE_DIR@
+endif EOS_ENABLE_COVERAGE
# Generated files that 'make clean' should erase
CLEANFILES =