summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-09-04 18:00:01 -0700
committerPhilip Chimento <philip@endlessm.com>2013-09-04 18:00:44 -0700
commit131798705325db7959243adfc1b5a7f96aeb35ce (patch)
tree5eba96212666134c922b7b837f419670b78a7fa9 /autogen.sh
parent2444b1473a980e770b9a85f93ecfb75efd97bbed (diff)
Use Automake's parallel test harness
This gets rid of a long-standing workaround and makes it easier to start using a proper test harness for Javascript unit tests. Unfortunately, it requires a workaround to be able to run gtkdoc-check on the documentation, but the workaround is not too bad. [endlessm/eos-sdk#122]
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh9
1 files changed, 0 insertions, 9 deletions
diff --git a/autogen.sh b/autogen.sh
index 9a98233..6c20886 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -32,15 +32,6 @@ if test -z "$NOCONFIGURE"; then
echo "environment."
fi
-am_ver=`automake --version | grep -m 1 -o '[^ ]*$'`
-# Autmake 1.11.x doesn't grasp the 'serial-tests' option. Add a m4 file which
-# defines HAS_SERIAL_TESTS_OPTION so we can keep our configure.ac forward
-# compatible
-case $am_ver in
- 1.11*|1.12*) echo '';;
- *) echo 'm4_define([HAS_SERIAL_TESTS_OPTION], [1])';;
-esac > m4/serial-tests.m4
-
# Run the actual tools to prepare the clean checkout
gtkdocize || exit $?
autoreconf -fi || exit $?