summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2013-05-01 18:35:44 -0700
committerEmmanuele Bassi <ebassi@gnome.org>2013-05-01 18:37:35 -0700
commit40423289483d256f5380ea0bb5fc6971ec3c96c7 (patch)
tree80b18b1032991bb065e2a85397906598aa7e280d /configure.ac
parent2cb0efd85d34e748bd463661008e47adbf783209 (diff)
build: Use AC_CACHE_SAVE
The AC_CACHE_SAVE macro saves the state of the configure script, so that it can be restore from a known state without having to re-run all the checks. This should speed up the build. [endlessm/eos-sdk#52]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6edee89..8dbae59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,8 @@ LT_INIT([disable-static])
# Keep Autotools macros local to this source tree
AC_CONFIG_MACRO_DIR([m4])
+AC_CACHE_SAVE
+
# Variables to define
# -------------------
# Version numbers and macros
@@ -82,6 +84,8 @@ EOS_REQUIRED_MODULES_PRIVATE="$GLIB_REQUIREMENT $GOBJECT_REQUIREMENT $GIO_REQUIR
AC_SUBST(EOS_REQUIRED_MODULES)
AC_SUBST(EOS_REQUIRED_MODULES_PRIVATE)
+AC_CACHE_SAVE
+
# Gettext package name
GETTEXT_PACKAGE=$PACKAGE
AC_SUBST(GETTEXT_PACKAGE)
@@ -151,6 +155,8 @@ PKG_CHECK_MODULES([EOS_SDK], [
$EOS_REQUIRED_MODULES
$EOS_REQUIRED_MODULES_PRIVATE])
+AC_CACHE_SAVE
+
# Output
# ------
# List files here that the configure script should output