summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Watson <mattdangerw@gmail.com>2013-06-19 23:48:51 -0700
committerMatt Watson <mattdangerw@gmail.com>2013-06-20 00:02:50 -0700
commit41cf9468100fdedb48af0f5658877a0a2c49e5b8 (patch)
tree62706129cdcf57479faf538af39973b527376ce7 /configure.ac
parentdde468286c1a240da7bd509a67a3d0619432142e (diff)
Added hack so configure works with automake 1.13 and 1.11
The problem was with needing the serial-tests option in 1.13 More details here http://gnu-automake.7480.n7.nabble.com/serial-tests-option-and-backwards-compatibility-td19571.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 524049b..74c167e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,10 +35,13 @@ AC_INIT([Open Endless SDK], [_EOS_SDK_VERSION_MACRO],
# Verify that the source directory can be found
dnl AC_CONFIG_SRCDIR([src/hello.c])
# Initialize Automake: enable all warnings and do not insist on GNU standards
-# Automake >= 1.13 required for serial-tests
# no-portability suppresses warnings about syntax specific to GNU make
-# serial-tests uses the old-style test suite
-AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.13 serial-tests])
+# If Automake >= 1.13 we need the serial-tests options
+# We use an serial-test.m4 file set up in autogen.sh to test if we need it
+m4_include([m4/serial-tests.m4])
+m4_ifdef([HAS_SERIAL_TESTS_OPTION],
+ [AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 serial-tests])],
+ [AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11])])
# Avoid spewing garbage over the terminal ('make V=1' to see the garbage)
AM_SILENT_RULES([yes])
# Initialize Libtool; don't build static libraries