summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-09-17 16:47:30 -0700
committerPhilip Chimento <philip@endlessm.com>2013-09-19 14:24:11 -0700
commit4549971954b8b67ed714048730060c9f66f4f56f (patch)
tree8643ba92fb425b0011c4468dbf76915eac989c83 /configure.ac
parentbf158e4986b6bf5570de2f6bd9de9e4be9b96608 (diff)
Documentation for WebHelper
This adds the infrastructure for autogenerating HTML documentation from a Javascript module using NaturalDocs, and then adds documentation comments to webhelper.js. [endlessm/eos-sdk#302]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a74e3e0..057f98e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,8 @@ AC_PATH_PROG([GIRDOCTOOL], [g-ir-doc-tool], [notfound])
AC_ARG_VAR([GIRDOCTOOL], [Path to g-ir-doc-tool])
AC_PATH_PROG([YELPBUILD], [yelp-build], [notfound])
AC_ARG_VAR([YELPBUILD], [Path to yelp-build])
+AC_PATH_PROG([NATURALDOCS], [naturaldocs], [notfound])
+AC_ARG_VAR([NATURALDOCS], [Path to naturaldocs])
GLIB_COMPILE_RESOURCES=`$PKG_CONFIG --variable glib_compile_resources gio-2.0`
AC_SUBST(GLIB_COMPILE_RESOURCES)
@@ -175,12 +177,22 @@ AS_IF([test "x$enable_gir_doc" = "xyes"], [
[AC_MSG_ERROR([yelp-build must be installed for --enable-gir-doc])])])
AM_CONDITIONAL([ENABLE_GIR_DOC], [test "x$enable_gir_doc" = "xyes"])
-# For 'make dist' or 'make distcheck', both --enable-gtk-doc and
-# --enable-gir-doc are required
+# --enable-js-doc: Build pure Javascript module documentation.
+AC_ARG_ENABLE([js-doc],
+ [AS_HELP_STRING([--enable-js-doc],
+ [Build documentation for pure Javascript modules @<:@default=no@:>@])])
+AS_IF([test "x$enable_js_doc" = "xyes"], [
+ AS_IF([test "x$NATURALDOCS" = "xnotfound"],
+ [AC_MSG_ERROR([NaturalDocs must be installed for --enable-js-doc])])])
+AM_CONDITIONAL([ENABLE_JS_DOC], [test "x$enable_js_doc" = "xyes"])
+
+# For 'make dist' or 'make distcheck', all three of --enable-gtk-doc,
+# --enable-gir-doc, and --enable-js-doc are required
AC_MSG_CHECKING([whether this configuration allows building distributions])
can_make_dist=yes
AM_COND_IF([ENABLE_GTK_DOC], [], [can_make_dist=no])
AM_COND_IF([ENABLE_GIR_DOC], [], [can_make_dist=no])
+AM_COND_IF([ENABLE_JS_DOC], [], [can_make_dist=no])
AM_CONDITIONAL([CAN_MAKE_DIST], [test "x$can_make_dist" = "xyes"])
AC_MSG_RESULT([$can_make_dist])