summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-12-03 16:30:14 -0800
committerPhilip Chimento <philip@endlessm.com>2013-12-03 16:30:14 -0800
commit45eeae314d6d20df7629f85eda49a89c122d9112 (patch)
tree30f6fd04009b4d8c2530106666cbf35dce76ad7c /configure.ac
parent880f05d9261d4aa2184230e3c4feb877495de7a0 (diff)
Remove {GTK,GLIB}_CHECK_VERSION
This removes all conditionally compiled parts for GTK < 3.10 and GLib < 2.38. [endlessm/eos-sdk#420]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b6551aa..7eea226 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,10 +76,10 @@ AC_SUBST(EOS_SDK_LT_VERSION_INFO)
# Required versions of libraries
# Update these whenever you use a function that requires a certain API version
-GLIB_REQUIREMENT="glib-2.0 >= 2.36"
+GLIB_REQUIREMENT="glib-2.0 >= 2.38"
GOBJECT_REQUIREMENT="gobject-2.0"
GIO_REQUIREMENT="gio-2.0"
-GTK_REQUIREMENT="gtk+-3.0 >= 3.4"
+GTK_REQUIREMENT="gtk+-3.0 >= 3.10"
# These go into the pkg-config file as Requires: and Requires.private:
# (Generally, use Requires.private: instead of Requires:)
EOS_REQUIRED_MODULES=