summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorP. F. Chimento <philip.chimento@gmail.com>2013-05-16 15:27:22 +0200
committerP. F. Chimento <philip.chimento@gmail.com>2013-05-16 15:27:22 +0200
commit6316854dac384585ed29a81d88184f788976400c (patch)
tree394289045d31d33a3da23cc041a301f6660315e7 /configure.ac
parentab5921b74431197b63f8b4be432560c9e01b7425 (diff)
Ensure that Gtk-Doc and GIR doc are enabled for distributions
'make dist' and 'make distcheck' do not work without calling ./configure --enable-gtk-doc --enable-gir-doc. [endlessm/eos-sdk#86]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2841fa8..d5d21bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,6 +172,15 @@ AS_IF([test "x$enable_gir_doc" = "xyes"], [
[AC_MSG_ERROR([yelp-build must be installed for --enable-gir-doc])])])
AM_CONDITIONAL([ENABLE_GIR_DOC], [test "x$enable_gir_doc" = "xyes"])
+# For 'make dist' or 'make distcheck', both --enable-gtk-doc and
+# --enable-gir-doc are required
+AC_MSG_CHECKING([whether this configuration allows building distributions])
+can_make_dist=yes
+AM_COND_IF([ENABLE_GTK_DOC], [], [can_make_dist=no])
+AM_COND_IF([ENABLE_GIR_DOC], [], [can_make_dist=no])
+AM_CONDITIONAL([CAN_MAKE_DIST], [test "x$can_make_dist" = "xyes"])
+AC_MSG_RESULT([$can_make_dist])
+
# Required libraries
# ------------------
PKG_CHECK_MODULES([EOS_SDK], [