summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorP. F. Chimento <philip.chimento@gmail.com>2013-04-07 04:19:32 +0200
committerP. F. Chimento <philip.chimento@gmail.com>2013-04-17 17:15:52 +0200
commit89671a4914caf1e20ea20a19c6bff7a058ebb3c4 (patch)
treea99b4544f888cfe6b6bbf99c4e0519117d40e89d /configure.ac
parent408f93ec2327a8647030139a2e6f295e8b2c8de1 (diff)
Internationalize the shared library
Add infrastructure for translating the single string in the shared library. [#1]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2404b5..ecf750e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,6 +80,14 @@ EOS_REQUIRED_MODULES_PRIVATE="$GLIB_REQUIREMENT $GOBJECT_REQUIREMENT $GIO_REQUIR
AC_SUBST(EOS_REQUIRED_MODULES)
AC_SUBST(EOS_REQUIRED_MODULES_PRIVATE)
+# Gettext package name
+GETTEXT_PACKAGE=$PACKAGE
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, ["$GETTEXT_PACKAGE"],
+ [Package name for Gettext])
+# Detect which languages are available
+AS_ALL_LINGUAS
+
# Configure options
# -----------------
# --enable-strict-flags: Compile with strict compiler flags. Done automatically
@@ -125,6 +133,9 @@ AC_SUBST(STRICT_CFLAGS)
AC_PROG_CC
# Library configuration tool
PKG_PROG_PKG_CONFIG
+# Gettext
+AM_GNU_GETTEXT([external])
+AM_GNU_GETTEXT_VERSION([0.18.1])
# Required libraries
# ------------------
@@ -137,8 +148,10 @@ PKG_CHECK_MODULES([EOS_SDK], [
# List files here that the configure script should output
AC_CONFIG_FILES([
Makefile
+ po/Makefile.in
$EOS_SDK_API_NAME.pc
])
+AC_CONFIG_HEADERS([config.h]) dnl Header with system-dependent #defines
# Do the output
AC_OUTPUT