summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-05-14 12:32:46 -0700
committerPhilip Chimento <philip@endlessm.com>2015-05-20 17:24:49 -0700
commita47ad9418cee71920d293fdae0f3c1589a1d50d0 (patch)
tree5f1c975cc1cf0b1eda0ba2c4fac3dfe48451100e /configure.ac
parent596b01daa99d8a5d1605cb57a4bbc6e7b0045edf (diff)
Check for webhelper's required GIR files
Make sure that the necessary GIR packages are installed before building. [endlessm/eos-sdk#291]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4bc10e6..2f1d344 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,6 +217,9 @@ PKG_CHECK_MODULES([EOS_SDK], [
$EOS_REQUIRED_MODULES
$EOS_REQUIRED_MODULES_PRIVATE])
+# Check installed GIRs for webhelper JS module
+EOS_CHECK_GJS_GIR([GLib], [2.0])
+EOS_CHECK_GJS_GIR([WebKit], [3.0])
# Code coverage reports support
EOS_COVERAGE_REPORT([c js])