summaryrefslogtreecommitdiff
path: root/docs/reference/endless/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-02-20 18:33:19 +0000
committerP. F. Chimento <philip.chimento@gmail.com>2018-03-21 12:14:59 -0700
commit4caf9df8b070140ee62218d3ea678f9732c1b8a7 (patch)
tree3e8cda6fef7671840387f938e671a72ba8933dd5 /docs/reference/endless/Makefile.am
parente53d0ffdd87927e1a8cdeed2f3d15e0fd102c8cc (diff)
Build man page and reference for eos-profile
Documenting CLI tools that we ship should be part of the API reference.
Diffstat (limited to 'docs/reference/endless/Makefile.am')
-rw-r--r--docs/reference/endless/Makefile.am30
1 files changed, 29 insertions, 1 deletions
diff --git a/docs/reference/endless/Makefile.am b/docs/reference/endless/Makefile.am
index c5143ef..3fa85a6 100644
--- a/docs/reference/endless/Makefile.am
+++ b/docs/reference/endless/Makefile.am
@@ -73,7 +73,9 @@ HTML_IMAGES=
# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
# e.g. content_files=running.sgml building.sgml changes-2.0.sgml
-content_files=
+content_files=\
+ eos-profile.xml \
+ $(NULL)
# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
# These files must be listed here *and* in content_files
@@ -106,3 +108,29 @@ TESTS_ENVIRONMENT = \
export BUILDDIR=$(abs_builddir);
TESTS = $(GTKDOC_CHECK)
endif
+
+man_MANS =
+
+if ENABLE_MAN
+
+man_MANS += \
+ eos-profile.1 \
+ $(NULL)
+
+XSLTPROC_FLAGS = \
+ --nonet \
+ --stringparam man.output.quietly 1 \
+ --stringparam funcsynopsis.style ansi \
+ --stringparam man.th.extra1.suppress 1 \
+ --stringparam man.authors.section.enabled 0 \
+ --stringparam man.copyright.section.enabled 1 \
+ $(NULL)
+
+.xml.1:
+ $(AM_V_GEN) $(XSLTPROC) $(XSLTPROC_FLAGS) http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+endif
+
+CLEANFILES ?=
+CLEANFILES += $(man_MANS)
+EXTRA_DIST += $(man_MANS)