summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-06-28 22:06:06 -0700
committerPhilip Chimento <philip@endlessm.com>2013-06-28 22:06:06 -0700
commitcf480c9de94a74fb705d00b4c6ac8390cbfdaf6a (patch)
tree690b5040957ca0863a05be47f0bb5f828ad8d89c /docs
parentfe90102bc9ebd808a7abe7ce060d2182399e3899 (diff)
Make EosActionButton public and document it
Rename eosactionbutton-private.h to eosactionbutton.h, make sure it gets picked up in the documentation, include it in endless.h, make all the new public API documentation complete, and put the EosActionButtonSize enum documentation on the EosActionButton page. [endlessm/eos-sdk#133]
Diffstat (limited to 'docs')
-rw-r--r--docs/reference/endless/Makefile.am1
-rw-r--r--docs/reference/endless/endless-docs.xml2
-rw-r--r--docs/reference/endless/endless-sections.txt29
3 files changed, 25 insertions, 7 deletions
diff --git a/docs/reference/endless/Makefile.am b/docs/reference/endless/Makefile.am
index 00a813d..7131b0c 100644
--- a/docs/reference/endless/Makefile.am
+++ b/docs/reference/endless/Makefile.am
@@ -52,7 +52,6 @@ EXTRA_HFILES=
IGNORE_HFILES= eosinit-private.h \
eostopbar-private.h \
eosmainarea-private.h \
- eosactionbutton-private.h \
eosactionmenu-private.h \
eospagemanager-private.h
diff --git a/docs/reference/endless/endless-docs.xml b/docs/reference/endless/endless-docs.xml
index 1d63323..e11497c 100644
--- a/docs/reference/endless/endless-docs.xml
+++ b/docs/reference/endless/endless-docs.xml
@@ -20,8 +20,8 @@
<xi:include href="xml/application.xml"/>
<xi:include href="xml/window.xml"/>
<xi:include href="xml/page-manager.xml"/>
- <xi:include href="xml/enums.xml"/>
<xi:include href="xml/splash-page-manager.xml"/>
+ <xi:include href="xml/action-button.xml"/>
<!--<xi:include href="xml/hello.xml"/>-->
</chapter>
diff --git a/docs/reference/endless/endless-sections.txt b/docs/reference/endless/endless-sections.txt
index 88db2b2..a02e5c7 100644
--- a/docs/reference/endless/endless-sections.txt
+++ b/docs/reference/endless/endless-sections.txt
@@ -89,11 +89,6 @@ EosPageManagerPrivate
</SECTION>
<SECTION>
-<FILE>enums</FILE>
-EosActionButtonSize
-</SECTION>
-
-<SECTION>
<FILE>splash-page-manager</FILE>
EosSplashPageManager
eos_splash_page_manager_new
@@ -115,3 +110,27 @@ eos_splash_page_manager_get_type
<SUBSECTION Private>
EosSplashPageManagerPrivate
</SECTION>
+
+<SECTION>
+<FILE>action-button</FILE>
+EosActionButton
+eos_action_button_new
+eos_action_button_get_icon_id
+eos_action_button_set_icon_id
+eos_action_button_get_label
+eos_action_button_set_label
+eos_action_button_get_size
+eos_action_button_set_size
+EosActionButtonSize
+<SUBSECTION Standard>
+EOS_ACTION_BUTTON
+EOS_ACTION_BUTTON_CLASS
+EOS_ACTION_BUTTON_GET_CLASS
+EOS_IS_ACTION_BUTTON
+EOS_IS_ACTION_BUTTON_CLASS
+EOS_TYPE_ACTION_BUTTON
+EosActionButtonClass
+eos_action_button_get_type
+<SUBSECTION Private>
+EosActionButtonPrivate
+</SECTION> \ No newline at end of file