summaryrefslogtreecommitdiff
path: root/endless/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-04-10 12:17:07 +0100
committerP. F. Chimento <philip.chimento@gmail.com>2013-04-17 17:14:21 +0200
commit408f93ec2327a8647030139a2e6f295e8b2c8de1 (patch)
treec0a796adc7ca6981b8eb0b53e8c21b5101dd2962 /endless/Makefile.am
parent5299f7acf85200a46679334a6bd230d4e2101b7f (diff)
Skeleton build system to build a shared library
Builds a dummy shared library that exports one symbol for testing, eos_hello_sample_function(). [#1]
Diffstat (limited to 'endless/Makefile.am')
-rw-r--r--endless/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/endless/Makefile.am b/endless/Makefile.am
new file mode 100644
index 0000000..92c9ab3
--- /dev/null
+++ b/endless/Makefile.am
@@ -0,0 +1,27 @@
+# Copyright 2013 Endless Mobile, Inc.
+
+endless_public_installed_headers = endless/endless.h
+
+endless_private_installed_headers = \
+ endless/apiversion.h \
+ endless/enums.h \
+ endless/macros.h \
+ endless/types.h
+
+endless_library_sources = \
+ endless/hello.c
+
+# Endless GUI library
+lib_LTLIBRARIES = libendless-@EOS_SDK_API_VERSION@.la
+libendless_@EOS_SDK_API_VERSION@_la_SOURCES = \
+ $(endless_public_installed_headers) \
+ $(endless_private_installed_headers) \
+ $(endless_library_sources)
+libendless_@EOS_SDK_API_VERSION@_la_CPPFLAGS = \
+ @EOS_SDK_CFLAGS@ \
+ -DCOMPILING_EOS_SDK
+libendless_@EOS_SDK_API_VERSION@_la_CFLAGS = $(AM_CFLAGS)
+libendless_@EOS_SDK_API_VERSION@_la_LIBADD = @EOS_SDK_LIBS@
+libendless_@EOS_SDK_API_VERSION@_la_LDFLAGS = \
+ -version-info @EOS_SDK_LT_VERSION_INFO@ \
+ -export-symbols-regex "^eos_"