summaryrefslogtreecommitdiff
path: root/endless/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2014-01-08 16:51:39 -0500
committerPhilip Chimento <philip@endlessm.com>2015-03-25 17:42:34 -0700
commit67c212e47a1db5f3e3dd1abaf552052e46512c93 (patch)
tree84d7d7906b033e502561c4136efeda68312cc6bc /endless/Makefile.am
parent88a142a202a3ae5e82f222cbb5ce75372d66e719 (diff)
Initial implementation of image credits
This is a rough implementation of an "About"-like dialog for image attribution in SDK applications. You can press the 'secret' hotkey Shift+Ctrl+A to get a dialog with thumbnails and attribution information for the images in the app's GResource. Clicking on the thumbnail opens the image's original URI in the browser, if known. Clicking on the text opens the image's license text in the browser, if known. For this, you need to add a JSON file to the app's GResource and pass its GResource path to the EosApplication:image-attribution-file property. The format of this JSON file is described in the documentation for EosApplication. The dialog uses GtkTreeView because we didn't have GtkListBox when I started implementing it over a year ago. This places some limitations on the UI; the links behave weirdly and the mouse pointer doesn't change to a hand when hovering over the links. [endlessm/eos-sdk#2934]
Diffstat (limited to 'endless/Makefile.am')
-rw-r--r--endless/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/endless/Makefile.am b/endless/Makefile.am
index 414a029..2cdca90 100644
--- a/endless/Makefile.am
+++ b/endless/Makefile.am
@@ -37,6 +37,9 @@ endless_private_installed_headers = \
endless_library_sources = \
endless/eosapplication.c \
+ endless/eosattribution.c endless/eosattribution-private.h \
+ endless/eoscellrendererpixbuflink.c endless/eoscellrendererpixbuflink-private.h \
+ endless/eoscellrenderertextlink.c endless/eoscellrenderertextlink-private.h \
endless/eoscustomcontainer.c \
endless/eoshello.c \
endless/eosinit.c endless/eosinit-private.h \